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Effective Macromedia Flash MX movies, even
very simple ones, often rely on symbols and

instances. Just what can symbols and
instances do for you? Symbols enable

you to create very complex movies that
are faster to download. How? Symbols
are downloaded only once, regardless
how many copies (called “instances”)
you have in your movie. For example,
if you had a symbol of a tree and
you added 50 instances of that tree
to the Stage, the file size would be
not be that much larger. However, 
if you were to instead draw 50 sepa-
rate trees, the user would have to

download all 50 trees, and the file
size would increase dramatically.

The concept of symbols and instances
is often one of the hardest things to teach

and learn in Macromedia Flash MX, because
this way of working doesn’t exist in many other

common graphics, animation, or interactive pro-
grams. I am confident, however, that if you try these

exercises you will better understand how to work more
easily with symbols and instances than if you just read about

them. Here’s where the premise of a hands-on training book is
really worth its weight in gold. For many, trying something and gaining 

first-hand experience is the key to understanding!

6.
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| Library | Registration Point | Creating Symbol Instances |
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The Symbol and Instance Structure
A Macromedia Flash MX symbol is a master object of sorts. You create a symbol once—it can be a
simple shape or something very complex—and use it multiple times throughout your movie. Each time
you reuse a symbol in your project file, it is called an instance, which is a copy of a symbol.

The concept of symbols and instances is the key to reducing the download weight of your Macromedia
Flash MX documents, because the symbol is downloaded only once, while the instances are simply
described in a small text file by their attributes (scale, color, transparency, animation, etc.). That is why
instances add very little to the file size of your final movie. To reduce the file size, you should create
symbols for any object that you reuse in your projects. Besides reducing the final file size, symbols and
instances can also help you make quick updates to objects across your entire project file. Later in the
book, as you learn about more advanced animation techniques, you’ll see that symbols and instances
play another dramatic role. But that’s skipping ahead! This chapter focuses on one concept alone—how
to create and manipulate symbols and instances.

There are three types of symbols in Macromedia Flash MX: Graphic symbols, Button symbols, and
Movie Clip symbols. In this chapter, you will be working with Graphic symbols. Hands-on exercises 
for creating Button and Movie Clip symbols are covered in later chapters.

Here’s a handy chart that explains some of the terms found in this chapter:

Symbol Definitions

Term Definition

Symbol A reusable object that serves as a master from which you can create copies
(instances). Once a symbol is created, it automatically becomes part of the
project file’s Library. You will learn about the Library later in this chapter.

Instance A copy of the original symbol. You can alter the color, size, shape, and position
of an instance without affecting the original symbol.

Graphic Symbol One of the three types of symbols. It consists of artwork that can be either
static or animated. The Graphic Symbol Timeline is dependent on the Main
Timeline—it will play only while the Main Timeline is playing. You’ll learn
more about this behavior as you work through the exercises in this book.
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Symbol Naming Conventions
As you learn to create symbols and instances in this chapter, you’ll need to create names for them. In
past versions of Macromedia Flash, it didn’t matter what name you gave to symbols or instances. With
ActionScripting in Macromedia Flash MX (which you will learn about later in this book), naming con-
ventions are more important than they used to be. This is especially true for Movie Clip symbols. For
this reason, I recommend that you get used to naming all your symbols in Macromedia Flash MX fol-
lowing the same rules, so you don’t develop bad habits that bite you down the road. Here’s a handy
chart that explains the rules.

Naming Symbols

Convention Explanation

No spaces Don’t use any spaces. Instead, string the words together or add
underscores. For example, instead of my first symbol, use the name
myFirstSymbol or my_first_symbol.

No special characters Special characters—such as ˚˙©¢ £¢¬ ˚ ˆ´ ´ºø)@#(%$T(%—
are forbidden. Some special characters have specific meaning to
the Macromedia Flash MX Player and can mess up ActionScripting
in the future, so be sure to avoid them.

No forward slashes Forward slashes are often misinterpreted as path locations on a
hard drive, instead of as the name of an object. So, for example,
don’t use the name my/first/symbol.

Begin with a Symbol names that begin with numbers can cause confusion in 
lowercase letter ActionScripting. For this reason, always start your symbol names

with a lowercase letter. Names can contain numbers, but the first
character should be a letter.

No dots Don’t put dots in your file names, such as snow.boarder—dots are
reserved for ActionScripting syntax.

Use a descriptive name It is good practice to use descriptive names for symbols. Rather
than symbol6, you should choose a name that is more easily recog-
nized, like gfxLogoBkgd. When you use multiword names for symbols,
capitalize the first letter of all words except the first so that you can
read it more easily. When you refer to an object in ActionScripting
(which you’ll get to try in later chapters), you must refer to the symbol
with the same capitalization you used in its name.
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Important Timeline Vocabulary Terms
This chapter reintroduces you to the Timeline. In the following exercises, you will learn that a symbol has
a Timeline too, and therefore you may have one Macromedia Flash MX project that contains several dif-
ferent Timelines. The following chart will help you further understand the distinctions among the various
types of Timelines.

Timeline Definitions

Term Definition

Main Timeline When you open a Macromedia Flash MX project (.fla), it always
defaults to showing the Timeline of Scene 1. This is also called
the Main Timeline in the Macromedia Flash MX documentation.
The Main Timeline is the Timeline that is visible when you’re
inside a scene. (You will learn all about scenes in Chapter 11,
“ActionScripting Basics.”)

Graphic Symbol Timeline Each Graphic symbol has its own Timeline, called a Graphic
Symbol Timeline. The Timeline for a symbol and the scene in
which the symbol is placed must have the same number of
frames, or the symbol’s animation will not play properly. This is
important because Movie Clip symbols, which you’ll learn about
in Chapter 10, “Movie Clips,” do not behave this way.

Scene’s Timeline Every Macromedia Flash MX project (.fla) has a Main Timeline 
in the form of Scene 1’s Timeline. You’ll see in later chapters
that Macromedia Flash MX projects can have multiple scenes. 
In those cases, each scene is considered part of the Main
Timeline. Learning the difference between a scene’s Timeline
and a symbol’s Timeline is one of the key foundations to work-
ing successfully with Macromedia Flash MX.
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Creating Graphic Symbols

Symbols are used for many purposes in Macromedia Flash MX. Before you learn hands-on what they’re
good for, you’ll need to know how to create them. This first exercise shows you how to create a Graphic
symbol. Later in the book, you’ll learn to work with the two other symbol types—Buttons and Movie
Clips—which are more difficult.

1.

1. Copy the chap_06 folder, located on the H•O•T CD-ROM, to your hard drive. You need to
have this folder on your hard drive in order to save changes to the files inside it.

2. Open the graphicSymbol.fla file from the chap_06 folder. This file contains one layer with
a snowflake shape in Frame 1. You will be converting this shape into a Graphic symbol in the
steps that follow.
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3. Choose Window > Library to open the Library panel. Notice that the project file name is displayed
at the top of the Library panel.

NOTE | What Is the Library?

The Library is a container where Macromedia Flash MX stores and organizes symbols, bitmap
graphics, sound clips, and video clips. For designers, it can be one of the most useful and fre-
quently used interface elements in the program. The Library is attached to the movie that you’re
working with. If you give your project file (.fla) to someone else and that person opens it, he or
she will see the same Library that you see when you have that file open. Additionally, you can
even open just the Library from another project file by choosing File > Open as Library.

Inside the Library, you can sort the contents by name, type, usage, and linkage. As your files
become more complex, you will find it useful to create folders within your Library to help separate
your symbols into different categories. Since you will frequently work with the Library in Macromedia
Flash MX, it’s useful to learn the two shortcuts to bring the Library to the screen: F11 or Ctrl+L
(Windows) or Cmd+L (Mac). You will get an in-depth look at the Library and all its functions in
later chapters.

Project 
file name

The Library
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4. Using the Arrow tool, select the snowflake on the Stage and drag it into the lower half of the
Library panel. This will open the Symbol Properties dialog box.

Note: Instead of dragging the shape into the Library, you can also select the shape and choose
Insert > Convert to Symbol to open the Symbol Properties dialog box.
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NOTE | The Symbol Properties Dialog Box

The Symbol Properties dialog box offers two views: basic and advanced. For now, we will stick
to the basic view. Inside the Symbol Properties dialog box are three settings to be determined next:
the name, the behavior, and the Registration Point of the symbol.

Basic view

Advanced view
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5. For Name, type snowflake; for Behavior, select Graphic; and for Registration, make sure the box
in the middle of the square is selected. Click OK.

Note: I promise that you’ll get to learn about Movie Clip and Button symbols in later chapters. For
now, you’ll focus on Graphic symbols only.

NOTE | What Is a Registration Point?

When you convert a shape into a symbol, Macromedia Flash MX needs to know where you want
the center point to be located on that shape. Who cares, you might be thinking. Well, it becomes
very important when you create animation using rotation because the symbol will rotate around its
Registration Point. If this seems a bit abstract to you, it will make more sense once you have com-
pleted Exercise 5 later in the chapter. For now, make sure the Registration Point is in the middle.

Once you click OK, the snowflake on the stage will change slightly. Notice the bounding box
and the circle with a crosshair in the middle of the snowflake. This provides visual feedback that
your snowflake is now a Graphic symbol. The circle and crosshair in the middle of the snowflake
act as a marker, telling you where the center (or Registration Point) of the symbol is. This is an
important indicator because it affects how all of the instances (which you will learn about in the
next exercise) of this symbol are rotated and scaled. You will also learn how to rotate and scale
instances later in this chapter.

Selected snowflake
shape before it is 

converted to a symbol

Selected snowflake
shape after it is 

converted to a symbol

Registration Point
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6. After you click OK in the Symbol Properties dialog box, notice that you now have two snowflakes in
your project file: the snowflake symbol, which is located in the Library, and an instance (a copy of the
original symbol) on the Stage. Instances are placed on the Stage, and symbols are stored in the Library.

Congratulations! You have just made your first Graphic symbol. In the next exercise, you will learn to
work with symbol instances.

7. Save and close the file.

Symbol Preview Window
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TIP | Five Ways to Create a Symbol

When you are working with Macromedia Flash MX, there are five different ways to create 
a symbol. You can create a symbol using artwork that already exists on the Stage or create 
a new symbol from scratch on a blank Stage. The five ways are explained below:

1. Select premade artwork on the Stage and drag it into the Library, as you did in step 4 of 
the previous exercise. This will turn the artwork you select into a symbol.

2. Select premade artwork on the Stage and choose Insert > Convert to Symbol, or use 
the shortcut key F8. This will also turn the artwork you select into a symbol.

3. Choose Insert > New Symbol or use the shortcut key Ctrl+F8 (Windows) or Cmd+F8
(Mac). This places you in symbol editing mode with a blank canvas ready for you to add 
or create artwork.

4. Choose New Symbol from the Library Options menu in the upper right corner of the 
Library. This places you in symbol editing mode with a blank canvas ready for you to add 
or create artwork.

5. Click the New Symbol button in the bottom left corner of the Library. This will place you 
in symbol editing mode with a blank canvas ready for you to add or create artwork.
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Creating Symbol Instances

In the last exercise, you learned how to create a symbol. In this exercise, you will learn how to create
instances of a symbol in the Library. Instances are copies of the original symbol that can be modified
individually without affecting the symbol in the Library. You will learn to do this in the following steps.

2.

1. Open the instances.fla file from the chap_06 folder. This file contains two layers: a layer
named background, which contains a bitmap image, and a layer named instances where
you will place instances of a symbol just like the one in the last exercise. The background
layer has been locked so that you don’t accidentally add instances to that layer.
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2. Make sure the instances layer is selected. If it’s not, click to the right of the layer name to select
that specific layer.

3. Make sure the Library is open. If it is not, choose Window > Library (or press F11) to open the
Library for this file. Notice that there are two items in the Library: the snowflake symbol and something
called backgroundPic.jpg. You might be wondering how those elements got there. The snowflake was
saved as a symbol in this project file, and it automatically appears in the Library whenever you open
this project file, just like the snowflake symbol you created in Exercise 1. The backgroundPic item is 
a bitmap that was also saved as a Library element and is located on the background layer.

Bitmap image

Graphic symbol
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NOTE | Library Assets

In addition to storing symbols, the Library also stores other assets, such as imported bitmap and
vector graphics, sound clips, and video clips. It is easy to identify the different assets inside the
Library at a glance, since each type has a different icon associated with it.

Icons
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4. In the Library, click on the snowflake’s Graphic symbol icon, and drag it onto the Stage. When you
release the mouse button, an instance of the snowflake is placed on the Stage.

One key point to remember is that symbols are stored in the Library and instances are located on the
Stage. From every symbol, you can create as many instances as you want.
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5. Click and drag seven more snowflakes from the Library. This will create a total of eight instances on
your Stage. You can also insert instances by clicking in the Library’s Preview Window and dragging an
instance onto the Stage.

Clicking and dragging from the Library is one way to create instances on your Stage, but you can
also Ctrl+drag (Windows) or Option+drag (Mac) an instance on the Stage to create a duplicate of 
it without opening the Library.

6. Save the changes you made to this file. Keep this file open for the next exercise. You will learn how
to edit symbols next.

Preview Window
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Editing Symbols

The instances on your Stage have a special relationship with the symbol in the Library. This is often
referred to in computer programming circles as a parent/child relationship. One of the advantages 
of this relationship is that if you change a symbol in the Library, all of the instances on your Stage will
be updated. As you can imagine, this can save you a lot of time when you need to make large updates
across an entire project. This ability to make quick—and sometimes large—updates is one of the power-
ful advantages of using symbols and instances. In this exercise, you will modify the appearance of the
snowflake symbol to change all eight instances on the Stage.

3.

1. The file from the previous exercise should still be open. If you closed it, go ahead and
open the instances.fla file from the chap_06 folder.

2. Make sure your Library panel is open. If it’s not, press F11 to open it now.

Your Stage should look similar to the one shown above. If for some reason it does not, refer
to the previous exercise to learn how to create multiple instances of the snowflake symbol.
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3. In the Library, double-click on the Graphic symbol icon to the left of the snowflake symbol name.
Your Stage will change, because you are now editing the Timeline for the symbol, where you can create
or modify its contents. At this point, you are no longer working in the Main Timeline. Notice that the gray
(work) area around your Stage is gone, as is the bounding box around the symbol. When you’re in
symbol editing mode (inside a symbol), you will not see the work area, unless you are using the Edit 
in Place feature, which you will learn about later in this exercise. Notice also that the Information Bar
above the Stage shows two names: Scene 1 and snowflake. This is another indicator that you are no
longer working on the Main Timeline. Instead, you are inside the editing interface and Timeline for the
snowflake Graphic symbol.

TIP | Know Your Location

There are several ways to get into symbol editing mode. It’s so easy to get into and out of this
mode that you may not even be aware that you have switched views, so be constantly aware of
where you are while you work. Keep an eye on the Information Bar and make sure that you are
drawing, animating, or creating in the correct location of your project.

Information Bar

You are located
inside the symbol

Double-
click here
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4. In the Toolbox, select the Ink Bottle tool, and select black for the Stroke Color. Click on the
snowflake to add a stroke to the snowflake shape. Notice that as soon as you click on the shape 
with the Ink Bottle tool, the Preview Window in the Library is updated instantly to reflect the change
you made.

Note: In the Macromedia Flash MX documentation, the terms “outline” and “stroke” are at times used
interchangeably. As you may recall from Chapter 3, “Drawing and Color Tools,” you can add strokes
(sometimes called outlines) to objects that don’t already have a stroke applied to them with the Ink
Bottle, as you did in the previous step. You can also modify an existing stroke by selecting it and then
changing its width and appearance using the Property Inspector.

Ink Bottle

Stroke Color
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5. In the Information Bar, click on the underlined Scene 1 to return to the Main Timeline. You should
see the bitmap with the snow and sky again.

As soon as you click on the Scene 1 name, the gray work area appears again, and you see only 
the Scene 1 name, without the snowflake name next to it. Notice also that all of the instances of 
the snowflake now have a black stroke around them. Every time you modify a symbol, it affects all 
of the instances you have in your project file, just as you saw here. This can be a very powerful 
way to make changes throughout your project.

Gray work area
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6. Choose a snowflake instance on the Stage, and double-click on it. This will allow you to edit the
symbol in place, which means in the context of the other instances on the Stage. When you edit a
symbol in place, all the other objects on the Stage are dimmed to differentiate them from the symbol
you are editing. You can also edit the symbol in place by choosing Edit > Edit in Place.

TIP | Techniques for Editing Symbols

Editing an instance in place (double-clicking on the instance on the Stage) will produce the same
end result as editing the symbol in the Library (double-clicking on the Graphic symbol icon to the
left of the symbol name in the Library). Both techniques change the appearance of the master
symbol as well as all of its instances. The difference between the two techniques is that when 
you edit the symbol in the Library, you cannot see the Main Timeline. When you edit an instance
in place, you see a dimmed version of the Stage, and you can preview your changes in context
with the rest of the Stage on the Main Timeline before returning to the Main Timeline.

You are now in
the Edit in Place

environment

Artwork and
other instances

are dimmed
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7. Using the Arrow tool, double-click on the stroke around the snowflake to select it. Press the Delete
key to remove it. Instead of the stroke, you’ll make a change to the fill this time. It’s easy to change the
artwork for the symbol whenever the mood strikes you!

8. Use the Arrow tool to select the snowflake shape.

9. In the Property Inspector, click on the Fill Color box and choose a different shade of gray. Because
the snowflake was already selected, Macromedia Flash MX automatically updates the color of the
snowflake as soon as you select a color. Again, notice that all the other instances of the snowflake
change color as well!
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10. In the Information Bar, click on Scene 1 to return to the Main Timeline. You should see the back-
ground bitmap and the snowflake instances in full color.

11. Save the changes you made to this file. Leave this file open because you will use it in the next exercise.
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Editing Symbol Instances

In the previous exercise, you learned how to modify a symbol to make changes to all of the instances
on the Stage. But what do you do if you want to change the color of only one instance or of each
instance individually? You can do this by selecting the instance on the Stage in the Main Timeline and
modifying the setting in the Property Inspector. The Property Inspector will let you change the tint,
brightness, and alpha settings of symbol instances. This is the only way to change the color values of
an instance because the Paint Bucket and Brush tools work only on shapes, not on symbol instances.
In this exercise, you will use the Property Inspector and the Free Transform tool to change the appear-
ance of individual snowflakes.

4.

1. The file from the previous exercise should still be open. If it’s not, open the instances.fla
file from the chap_06 folder.

2. Click to select the snowflake instance in the upper left corner of the Stage.

It’s very important that you select the snowflake instance by clicking on it only once. If you
double-click it accidentally, you will be editing the symbol, not the instance. If this happens,
go back to the Main Timeline by clicking on the Scene 1 link in the Information Bar.
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3. Make sure the Property Inspector is open and visible. If it’s not, choose Window > Properties or
use the shortcut Ctrl+F3 (Windows) or Cmd+F3 (Mac) to open it.

4. From the Color Styles box in the Property Inspector, choose Brightness. Click the slider to the
right of the menu and drag it up to 100%. This will increase the brightness level of the selected object
as you drag up.

Note: The Brightness option controls the brightness value of the instance and has a range of –100%
to 100%, with –100% being completely black and 100% being completely white.

5. Click to select a different snowflake on your Stage. You can choose any snowflake you want.

6. From the Color Styles box in the Property Inspector, choose Tint. The Tint option applies a tint to
the base color of your instance.

Color
Styles
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7. Click inside the Tint Color box and, from the pop-up color palette select a shade of purple.

8. Click and drag the Tint slider up to 75%. As you drag the slider up, notice how the color becomes
brighter. The Tint option has a range of 0% (no tint) to 100% (fully saturated). Basically, this is chang-
ing the amount of color that is applied to the instance. It also changes the RGB values in the Property
Inspector.

Note: You control the color of the instance by modifying the percentage of the tint being applied and
the individual RGB (red, green, and blue) values. The Tint option is the only way you can change 
the color of an instance, other than using the advanced settings, where you can set the RGB values.
This option also changes both the Fill and Stroke settings to the value you specify. You cannot change
these settings separately when editing the instance; this can be done only by editing the symbol.

Tint Color box

RGB values
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9. Click to select another snowflake on the Stage. Just make sure you select one that has not been
modified yet.

10. From the Color Styles box in the Property Inspector, choose Alpha. This option, which has a range
of 100% (opaque) to 0% (transparent), lets you control the transparency value of the selected instance.

11. Click and drag the Alpha slider down to 0%. Watch the selected snowflake disappear as you
drag the slider down. Return the Alpha slider to 30%.

In the next few steps, you will learn about the Advanced option in the Color Styles drop-down menu.
This option lets you modify multiple settings for a selected object. For example, you can use this option
to adjust the Tint and Alpha settings of the selected instance. The best way to learn about it is by
using it, and that’s exactly what you are going to do.
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12. Click to select another unmodified snowflake on the Stage.

13. From the Color Styles box in the Property Inspector, choose Advanced from the drop-down
menu. Click the Settings button.

14. In the Advanced Effect dialog box, click the arrow and drag the Red slider to 20%. Click and
drag the Green slider down to 60%. Click and drag the Alpha slider to 50%. The end result should
be a snowflake that is a nice shade of blue.

The left column of fields in the Advanced Effect dialog box allows you to manipulate the colors using
percentages, while the right column of fields allows you to manipulate the colors using numbers that
correspond with color values.

Note: Your snowflake might look a bit different if you didn’t select the same gray for your snowflake
symbol as I did in the last exercise.
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15. Go ahead and recolor as many snowflakes as you want. It never hurts to practice! For your refer-
ence, I have provided a chart at the end of this exercise that outlines all of the options in the Color
Styles drop-down menu.

So far, you’ve gained some experience in changing symbol instances by modifying their brightness,
tint, and alpha. You can also rotate, scale, and skew instances. In the following steps, you will use 
the Free Transform tool to modify the instances on your Stage.

16. Click to select another snowflake on your Stage. It doesn’t really matter which one you select
because you will eventually select them all.

NOTE | Removing Color Styles

Up to this point in this exercise, you have added many different color styles to the instances on
your Stage. If you want to remove the styles you have applied to an instance, you can simply
select the instance and choose the None option from the Color Styles drop-down menu. This 
will turn off any color styles you have applied and restore the instance to its original condition.
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17. In the Toolbox, select the Free Transform tool.

18. Click on the middle handle on the bottom of the snowflake and drag down. This will increase the
height of the snowflake.

19. Move your cursor between the bottom left and middle handles (slightly above the handles) until
you see the skew cursor icon, as shown in the picture above. Once you see the icon, click and drag 
to the left. This will skew the selected snowflake.

Selected snowflake
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20. Click to select another snowflake instance on the Stage.

21. Select the Free Transform tool in the Toolbox and click and drag diagonally on one of the corner
handles. This will scale the snowflake to a bigger size.

Tip: If you hold down the Shift key while you drag one of the handles, the snowflake will scale pro-
portionally on all sides.

22. Click to select a different snowflake instance on the Stage.

23. In the Toolbox, select the Free Transform tool and move your cursor over a corner handle until
the rotate icon appears, as shown in the picture above. Click and drag down. This will rotate the
selected snowflake.
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24. Go ahead and select the last snowflake on the Stage and, using the Free Transform tool, apply
any transformation you like. Remember, practice makes perfect, so have some fun creating your own
transformation of the last unchanged snowflake instance.

25. When you are finished, save the changes you made and close this file. You won’t need it anymore.

NOTE | Changing the Registration Point

When using the Free Transform tool, you might have noticed that the circle in the center of an
instance serves as an anchor from which position, rotation, and scale originate. It is possible to
move the center point (Registration Point) if you want to.

To change the Registration Point, make sure that both the Free Transform tool and the instance are
selected, and then click and drag the center circle to a new location. From then on, any transforma-
tions you make will originate from this new position. Use this technique when you want to rotate
from a corner; you can even move the Registration Point off the image to rotate on a distant axis.

Registration
Point in center

Instance being rotated with
Registration Point in center

Registration Point in
upper right corner

Instance being rotated with Registration
Point in upper right corner
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Color Styles
The chart below explains the different options available in the Color Styles drop-down menu in the
Property Inspector. As you learned in this exercise, the Color Styles options can be used to change 
the color and alpha properties of an instance.

Color Styles Options

Option Description

Brightness Controls the brightness (lightness or darkness) of the selected symbol. The
percentage slider goes from –100% (black) to 100% (white).

Tint Allows you to tint a selected symbol a specific RGB color. You can choose 
a color from the Tint color palette The slider allows you to add a tint to the
selected symbol with a percentage of that specific color. You can also choose 
a color by sliding the R, G, and B color sliders up and down.

Alpha Allows you to change the transparency of a selected instance. Using the slider,
you can have a completely opaque instance (100%) or a completely transparent
instance (0%), or any value in between.

Advanced A complex option that lets you adjust the tint and alpha of an instance. The
Using Macromedia Flash MX manual has a good explanation of the complex
mathematical equations involved with this panel. I find it easier to just play with
the different settings to get the right look.

Great job! You’ve made it this far; now you have only one more exercise to go. Next you will learn
how to make an animated Graphic symbol.
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Animating Graphic Symbols

Up until now, you have been working with static Graphic symbols. Now you will learn how to create 
a Graphic symbol that contains animation frames. When you use animated Graphic symbols in
Macromedia Flash MX, it’s important to understand that the number of animation frames inside the
symbol have to relate to the number of frames that are set on the Main Timeline. This will make more
sense to you after you try it.

In this exercise, you will modify the snowflake Graphic symbol and add a simple shape tween anima-
tion to its Timeline to convert it into an animated Graphic symbol. The end result will be a snowflake
that turns into a small snowball and fades away.

5.

1. Open the animSymbolFinal.fla file from the chap_06 folder. Choose Control > Test
Movie to preview the animation. It’s snowing! You will play Mother Nature and create the
snowing animation next.
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2. Close animSymbolFinal.fla and open the file named animSymbol.fla from the chap_06 folder. This
file is similar to the one you started with in Exercise 2. It contains two layers: one named background,
which contains a bitmap background image, and one named animSymbol, where you will place the
animated symbol you are about to create. The background layer has been locked so that you don’t
accidentally modify that layer.

3. Make sure the Library panel is open and visible. If it’s not, press F11 to open it. The Library contains
two items: backgroundPic.jpg, which is the background image, and a snowflake symbol.
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4. In the Library, double-click on the small Graphic symbol icon to the left of the word snowflake.
This will take you into editing mode for this symbol. Notice that the contents of your Stage have
changed and that the snowflake Graphic symbol icon appears in the Information Bar.

In the following steps, you will create a shape tween animation that will make the snowflake look as
though it is falling as it changes into a small snowball and fades away. Keep in mind that you are cre-
ating this animation of your snowflake on the Graphic Symbol Timeline, which is different from the
Main Timeline in Scene 1. This means that the animation will affect all the instances of this symbol,
because you are editing the master symbol.
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5. In the Timeline, press F7 on Frame 10 to add a blank keyframe to Frame 10. 

Remember, a blank keyframe identifies a change and does not copy any artwork from the 
previous keyframe.

6. In the Toolbox, select the Oval tool and set the Stroke to none and the Fill to white.

Oval tool

Stroke set to none

Fill set to white
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7. Draw a small circle directly below the Registration Point.

On Frame 1, your snowflake was centered on the Registration Point, and since you want to create 
an animation of the snowflake falling, you need to draw the circle below the Registration Point.

8. In the Graphic Symbol Timeline, click anywhere between Frame 1 and Frame 10 to select one of
the frames.

9. Make sure the Property Inspector is open. If it is not, press Ctrl+F3 (Windows) or Cmd+F3 (Mac).
Choose Shape from the Tween drop-down menu.

10. Press Enter/Return to get a quick preview of what your animation will look like. 

You still have one more tween to add.

Small circle

Registration Point
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11. Press F6 on Frame 20 to add a keyframe to Frame 20. With the Arrow tool, move the snowball
circle on Frame 20 down, as shown in the picture above.

The snowflake will turn into a snowball from Frame 1 to 10, and then the snowball will disappear
from Frame 10 to 20.

Move circle on Frame 20 here
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12. With the snowball circle still selected, set the Alpha to 0%. This will make the snowball in Frame
20 transparent. Click anywhere off the snowball to deselect it, and you will see it disappear!

13. In the Graphic Symbol Timeline, click anywhere between Frame 10 and Frame 20 to select one
of the frames.

14. Choose Shape from the Tween drop-down menu. This adds the tween animation of the snowball
falling and disappearing.

15. Press Enter/Return to preview the entire animation. As it is falling, the snowflake should turn into
a snowball, and then the snowball should fade away.

16. When you are happy with your animation, click on Scene 1 in the Information Bar to return to the
Main Timeline.
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17. Drag an instance of the snowflake symbol onto the Stage. This will add an instance of the ani-
mated snowflake symbol to the Main Timeline.

18. Choose Control > Test Movie. This will open a new window with a preview of your movie. But
wait; the snowflake is not animating. Why not? Close the Preview Window to return to Scene 1’s
Timeline, and I’ll show you how to fix this.

The Timeline of the animated Graphic symbol is directly related to the Main Timeline (the current
scene—in this case, Scene 1) of the project. This means that if the Main Timeline is one frame in
length, which it is, and the Timeline of the animated Graphic symbol is 20 frames in length, only 
one frame will be displayed. To fix this situation, you need to extend the Main Timeline to be at 
least as long as the Timeline of the animated Graphic symbol, which is 20 frames long.
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19. Click in Frame 20 of the animSymbol layer and drag down to Frame 20 of the background layer.
This will select the range of frames between the layers.

20. Press F5 to insert frames and extend the Timeline of both layers to 20 frames in length. Now the
Main Timeline is at least as long as the Timeline of the animated Graphic symbol, which means that
you will see the entire animation play. Your snowflake is about to animate!

Note: You just extended both layers so that the content of these layers is displayed for the same
length of time. For example, extending just the animSymbol layer would cause the background layer
to disappear when the Playhead reached Frame 2. Extending both layers to Frame 20 ensures that
all of the layers are displayed for the same length of time.

21. Choose Control > Test Movie once again to preview your movie. There you go: an animating
snowflake. However, in order to have the effect of snow falling, you need to add more instances to
your Stage. You will do this next.

22. Close the Preview Window.
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23. On the Main Timeline, drag 11 more instances of the animated snowflake symbol onto the
Stage, to make a total of 12 snowflakes on the Stage.

24. Choose Control > Test Movie. This will open a new window with a preview of your movie.

Notice that the snowflakes are all falling in unison, which doesn’t look very realistic. The following
steps will show you how to change the starting frames of each animated Graphic symbol to create 
a more natural-looking snowfall.

25. Close the Preview Window.

26. Click to select a snowflake on the Stage.

27. Enter any number between 1 and 20 in the First field, in the middle of the Property Inspector.
This field sets the frame on which the animation begins. Since this animation has a total of 20 frames,
you must select a number between 1 and 20.
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28. Repeat this process for all of the snowflakes on your Stage, entering a different First value for
each one. By changing the starting frame of each animation, you will change the starting point of 
each animation, and that will produce a more realistic snowfall effect.

29. Choose Control > Test Movie to preview your movie. It’s snowing! You can go ahead and close
the Preview Window.

Could you have achieved this same effect using a different method? The answer is yes. In Macromedia
Flash MX, it is often possible to produce the same effect in a number of different ways. However, some
ways are more efficient than others. The above example outlines an efficient way of using one symbol
to create several instances that look and behave very differently. You could have created and animated
each of the snowflakes separately to produce the same effect, but that would have been so much
more work.

30. Save the changes you made to this file and close it.

You made it! Congratulations! By now, you should feel a lot more comfortable working with symbols
and instances, and you should understand the role they can play in your projects. But you aren’t fin-
ished yet. Future chapters on Buttons and Movie Clips will continue this learning process. So don’t
stop now—you are just getting to the good stuff.

NOTE | Looping

You might have noticed that the 20-frame animation of the falling snowflakes played over and over
again when you tested the movie. This type of behavior is called a loop, which is an animation
sequence that repeats over and over. Macromedia Flash MX defaults to looping whatever is on
the Stage, unless you tell it not to through the use of ActionScript. You will learn about ActionScript
in Chapter 11, “ActionScripting Basics.”


