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Most of you have seen animations on the Web or
on television that show an object transforming

(or morphing) from one shape into another.
You can create this same effect in your

Macromedia Flash MX movies through 
a technique called shape tweening.

The exercises in this chapter offer 
a thorough introduction to shape
tweening. By working through them,
you will expand your Macromedia
Flash MX skill set to include shape
tweening, hinting, animating gradi-
ents, and multiple shape tweening.

5.
Shape Tweening

| What Is Shape Tweening? |

| Shape Tweening Text | Shape Hinting |

| Multiple Shape Tweening | Layer Folders |

| Layer Properties | Animating Gradients |

chap_05

Macromedia Flash MX
H•O•T CD-ROM
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What Is Shape Tweening?
Shape tweening works like this. If you wanted to create an animation that showed a square transform-
ing into a circle, you could create the starting point of the animation—the square—and the ending point—
the circle—by placing them on separate keyframes, leaving empty frames between them. You could then
set up a shape tween and have Macromedia Flash MX automatically generate the art for the empty
frames between the two images.

Before I describe shape tweening in more detail, I first need to define a few terms—shape, keyframes,
and tweening. Here’s a handy chart to refer to if these terms are new to you:

Shape Tweening Definitions

Shape

In Macromedia Flash MX, a shape is a vector-based object or
series of objects. You can create shapes in Macromedia Flash MX
using any of the drawing tools, or you can bring shapes into
Macromedia Flash MX from other vector-creation programs, such
as Freehand or Illustrator. In order for a shape to be suitable for
shape tweening, it cannot be composed of grouped objects,
bitmaps, or symbols. (You will learn about symbols in Chapter 6,
“Symbols and Instances.”) Type can be the subject of a shape
tween if it is first converted to a shape. This process is called
“breaking apart.” You will learn how to break type apart later in 
this chapter.

Keyframes

In traditional animation, a “key” or “lead” animator would draw
“extremes,” or the important frames of artwork that define what
the motion should look like. If, for example, you needed an anima-
tion of a circle turning into a square, a key artist would draw two
keyframes, the first with a circle and the second with a square.

In Macromedia Flash MX, a keyframe is symbolized in the
Timeline by a gray frame with a filled black circle at the bottom. 
In this example, the circle would be inside the first keyframe 
and the square would reside in the next keyframe.

continues on next page
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Macromedia Flash MX lets you use shape tweening to animate between lines and shapes and to ani-
mate the colors and gradients that are applied to them. This process is often referred to as morphing.
The illustrations that follow are a good example of a shape tween:

The first step in creating a shape tween is to create two unique keyframes.

The next step is to apply a shape tween to the frames with a few clicks of the mouse. Macromedia
Flash MX will then interpolate the difference between the keyframes and automatically generate all 
of the frames in between.

Shape Tweening Definitions continued

Tweening

The term “tweening” is borrowed from traditional cel animation 
terminology, and is slang for “in-betweening.” In cel animation, 
a person called an “in-betweener” would take the keyframes 
that a lead animator creates and draw all the frames that go
between them that describe the motion. For example, the
in-betweener would take the two keyframes just described 
and would use them to draw a series of images of the shapes 
in various stages of morphing from one object, the circle, into 
the other object, the square.

Keyframe 1 Keyframe 2
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Shape tweening is the only process in Macromedia Flash MX that lets you quickly animate from one
distinct shape to another. It can also be used to animate from one gradient to another, from one color
to another, and/or from one position to another. As you might imagine, creating this kind of animation by
drawing each frame of the artwork would be rather tedious. The shape tweening feature in Macromedia
Flash MX automates this process.

The lists that follow outline some of the things that you can and can’t do with shape tweens in
Macromedia Flash MX.

What Shape Tweening Can Do

• Tween the shape of an object

• Tween the color of an object (including a color with transparency)

• Tween the position of an object on the Stage

• Tween the transformation (scale, rotation, skew) of an object

• Tween text that has been broken apart

• Tween gradients

What Shape Tweening Can’t Do

• Tween grouped objects

• Tween symbols

• Tween text that has not been broken apart
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Shape Tweening Text

In the steps that follow, you will create an animation of a snowboard changing into the letter “X.” This
will introduce you to the basics of shape tweening.

1.

1. Copy the chap_05 folder, located on the H•O•T CD-ROM, to your hard drive. You will
need to have this folder on your hard drive in order to save changes to the files inside it.

2. Open the textTweenFinal.fla file from the chap_05 folder. This is a finished version of the
animation you will create in the following steps.

3. Press Enter/Return on the keyboard to preview the shape tweening animation. You will
see the snowboard artwork turn into the letter “X.” You will create this shape tween next.

4. Close the textTweenFinal.fla file.
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5. Open the textTween.fla file from the chap_05 folder. This file contains two layers: one named
boarding text with the word “boarding” on it and one named tween with the snowboard shape on 
it. You will be working on the layer named tween.

6. On the tween layer, press F7 on Frame 10. This adds a blank keyframe to Frame 10. You are adding
a blank keyframe rather than a keyframe because you want to add new artwork on Frame 10, not copy
the artwork from Frame 1.

Blank keyframe
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7. Notice that after the first frame, the word “boarding” disappears. This happens because the boarding
layer has only one frame, while the tween layer now has 10 frames. In order for the word “boarding” 
to appear throughout the entire animation, the boarding layer must also contain 10 frames. Click on
Frame 10 and press F5 on Frame 10 in the boarding layer to add frames up to Frame 10 on that layer.

8. In the Toolbox, select the Text tool. Select Frame 10 on the tween layer, click on the Stage, and
type the capital letter X in Frame 10 just before the letter “b” in the word “boarding,” as shown above.

Frame

Text tool
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Note: I used the Arial font, size 78, white, and bold to type the “X,” but you can use whatever font
and size you like. You will learn more about the text options in Macromedia Flash MX in Chapter 12,
“Working with Text.”

9. Using the Arrow tool, click to select the large X on the Stage. Drag the X to position it before the
letter “b,” with a little space between the “X” and the “b,” as shown above.

When you type text using the Text tool, the “X” is still in an editable format, which means you can
double-click on it at any time and change the letter to something else. If you deselect the text and
use the Arrow tool to select it again, you will see a blue bounding box and no selection mesh, indi-
cating that it is not a shape.

To use text in a shape tween, you have to make it a shape by breaking it apart. The act of breaking
text apart converts it from editable text into an editable shape. You must do this because editable
type cannot be the source of a shape tween. It’s one of the rules of shape tweening—you can’t 
use grouped objects or symbols either. While you might not think of type as a grouped object, by
Macromedia Flash MX’s definition it must be broken apart to become a shape. You will learn more
about working with text tools in Chapter 12.
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10. With the X still selected, choose Modify > Break Apart. The text is broken apart and converted
into a shape, ready to be shape tweened. The selection mesh over the “X” indicates that you are now
working with a shape. This will be the last keyframe of your animation.

11. Click anywhere between the two keyframes to select a frame in the middle of that range of frames.

12. Make sure the Property Inspector is open. If it is not, choose Window > Properties.

13. In the Property Inspector, click to see the Tween drop-down menu and select Shape to apply a
shape tween between the two keyframes.

Broken-apart text with selection mesh
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Once you have applied a shape tween between two keyframes, the Timeline will be shaded green and
a long arrow will appear between the keyframes. This is a visual indication that a shape tween is active.

14. Press Enter/Return to test your tween. You will see the snowboard turning into the letter “X”.

15. When you are finished testing, save this file and keep it open for the next exercise.

WARNING | Spotting Broken Tweens

As you work more with shape tweens (and motion tweens in Chapter 7, “Motion Tweening”), you
may see a broken (dashed) line appear in your Timeline instead of a solid line. Any time you see a
broken line in your Timeline, it means that the shape tween (or motion tween) is not working prop-
erly. This can make it easy to spot problems in your animations. If you do see a dashed line in the
Timeline when you are trying to create a shape tween, make sure that each of the objects in each
of the keyframes is in fact a shape and not a grouped object or text that hasn’t been broken apart.
You’ll learn more about the causes of broken shape tweens when you learn about symbols in
future chapters.

Shape tween
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Shape Hinting

When working with shape tweening, Macromedia Flash MX will automatically determine how to change
from one shape to the next. Because this is an automatic process, you don’t have complete control over
how the tween occurs. Shape hinting is a feature that helps you regain some control over a tween. It
is used primarily to fix a shape tween that does something you don’t want it to do. In this exercise, you
will take the shape tween that you created in the previous exercise and add shape hints to better con-
trol how the snowboard morphs into the “X”.

2.

1. You should still have the file from the previous exercise (textTween.fla) open. If you don’t,
go ahead and open it now.

2. Press Enter/Return to preview this shape tween.

Notice that, as the shape tween progresses, the snowboard appears to crumple up like a
piece of paper and then all of a sudden pop into the letter “X.” That is how Macromedia
Flash MX decided to create this shape tween. What if you want the tween to appear more
fluid? You’ll learn how to do this using shape hinting in the steps that follow.
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3. Make sure the Playhead is over Frame 1. When you add shape hints, you must start on the first
frame of your animation.

4. Choose Modify > Shape > Add Shape Hint.

5. A red circle with an “a” in it will appear in the middle of the snowboard. This is a shape hint. Click
and drag the shape hint to the upper left corner of the snowboard shape. Note: You must use the
Arrow tool from the Toolbox to do this.

6. Move the Playhead to the last frame (Frame 10) of your animation.
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7. Click and drag the shape hint (the small “a”) to the upper left inside corner of the X, as shown above.
This will make sure that the upper left corner of the snowboard ends up as the upper left corner of the
letter “X.”

When you let go of your mouse, notice that the shape hint changes from red to green. Why? This is
how you know that the shape hint has been accepted. When your shape hint doesn’t turn green on
the ending keyframe, it means that it was not placed in the same (or in a similar) location as the first
shape hint. The Macromedia documentation states that shape hints are yellow in the starting keyframe,
green in the ending keyframe, and red when they are not on a curve. However, this is not always the
case, as shown in this exercise, where the “X” shape has no curves but the hints still turn green. In
order for shape hints to work properly, your best bet is to place them in similar locations on each
keyframe and to pay more attention to how the tween animates than to the color of the hints. If nec-
essary, try repositioning your shape hint for a better tween effect. Sometimes it takes just a small
adjustment for Macromedia Flash MX to get the hint (pun intended)!

8. Press Enter/Return to preview the effect of changing the shape tween by using a shape hint.
Notice that the shape tween looks better. You will make the transition even smoother by adding more
shape hints next.

9. In the Timeline, click on Frame 1 to make sure the Playhead is over the first frame. Choose
Modify > Shape > Add Shape Hint to add another shape hint.

10. The second shape hint will appear as a small “b” in the middle of the snowboard. Click and drag
the second shape hint to the upper right corner of the snowboard shape, as in the picture above.
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11. Move the Playhead to the last frame (Frame 10) of your animation. Click and drag the second
shape hint (“b”) to the upper right outside corner of the X, as shown above.

12. Press Enter/Return to preview the effect of changing the shape tween by adding another shape
hint. Notice that the shape tween transition is getting better.

13. In the Timeline, click on Frame 1 to select the first frame. Repeat steps 9, 10, and 11 two more
times to add two more shape hints, moving them to the remaining corners of the “X.” When you are
finished, Frame 1 and Frame 10 should look like the pictures above.

TIP | Multiple Shape Hints

After you add a second shape hint, it appears as a red circle with the letter “b” rather than an “a”
in the middle of it. The next shape hint after that will be “c”, and so on. I think you see the pattern
here. When you get to “z”, that’s it! You’re all out of shape hints. You’re given a total of 26 shape
hints per shape tween. But don’t worry; 26 shape hints should be far too many for most anima-
tions. If you find yourself needing more than 26 shape hints, you might want to rethink the com-
plexity of your animation, as by then it is probably going to put a lot of strain on the end user’s
computer processor.



5. Shape Tweening | Macromedia Flash MX H•O•T

| 156 |

14. Press Enter/Return to test the shape tween with four shape hints.

Try experimenting by moving the shape hints around. Moving them even slightly can give a completely
different look to your shape tween. Now that you know how to add shape hints, you should learn how
to remove them as well. The following steps show you how to remove a shape hint.

15. Click and drag the Playhead back to Frame 1.

16. Right-click (Windows) or Ctrl+click (Mac) on the shape hint with a “d” on it. Choose Remove
Hint from the pop-up menu. This will remove the selected shape hint and returns the animation back to
the point of using just three shape hints.

17. Press Enter/Return to test the shape tween animation again. Go ahead and experiment removing
another shape hint and notice how it affects the animation.

18. When you are finished, save and close this file—you won’t need it to complete the next exercise.

TIP | Quickly Removing Shape Hints

If you add too many shape hints and really mess up your animation, don’t worry. You can remove
them all with just a few clicks. Right-click (Windows) or Ctrl+click (Mac) on any shape hint and
select Remove All Hints from the pop-up menu. You can also select Modify > Shape > Remove
All Shape Hints. Either option will remove every shape hint from your animation. Thank goodness
for this feature!
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Multiple Shape Tweening

So far, you have learned how to create single shape tweens. There will likely come a time, however,
when you will want to create more than one shape tween in your project. In this exercise, you will learn
how to create multiple shape tweens by placing them on separate layers using the Distribute to
Layers feature (new to Macromedia Flash MX). Working with multiple layers is the only way to choreo-
graph animations with multiple tweens. This exercise will also introduce the Layer Folder feature (also
new to Macromedia Flash MX), which is a wonderful way to organize and consolidate animations that
contain many different layers.

3.

1. Open the mutplShpTwnFinal.fla file from the chap_05 folder. This file contains a finished
version of the shape tween animation you are about to create.

2. Press Enter/Return on your keyboard to preview this file. If you can’t see the entire Stage,
choose View > Magnification > Show All so that you can see the whole multiple shape tween
animation. Notice the Folder icon in the Layers section of the Timeline, with all the layers in it.
This designates a Layer Folder, which you’ll learn about near the end of this exercise. When
you are finished previewing, close the file. You will learn to create this same animation in the
steps that follow.
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3. Open the file named mutplShpTwn.fla located inside the chap_05 folder. Currently, this file has
one layer with six different shapes on it.

Up to this point in the chapter, you have been creating shape tweens in which one shape turns into
another on one layer. While it is possible to tween one shape into many shapes using only one layer,
some effects require you to place your shapes on separate layers. The following steps show a good
example of when it’s necessary to put your shapes on separate layers.
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4. Click on Frame 1 to select all the shapes on Frame 1, and choose Modify > Distribute to Layers.

The Distribute to Layers feature will take each selected shape and place it on its own layer. You can
click on any of the shapes on the Stage, and you will see the corresponding layer become highlighted
in the Timeline, as shown above.

New layers
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5. Starting with Layer 2, double-click on each of the layer names to give them new, more descriptive
names. Change Layer 2 to left bottom, Layer 3 to left top, Layer 4 to middle, Layer 5 to right bottom,
and Layer 6 to right top, just as you see in the picture above. Make sure that the name you give to
each layer matches the shape’s location on the Stage. This makes it easier to know what shapes are
on each of the layers.

Layer name

Shape on this layer
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6. Starting with Frame 6 on the layer named left bottom, click and drag down to select Frame 6 on
all the layers below the left bottom layer, as shown above.

TIP | Revealing More of the Timeline

If you want to see more layers in the Timeline, you can use the scroll bars on the right side of the
Timeline, or you can click and drag to reveal more layers or even to see more of the layer names,
as shown above.

Click and drag up or down
Click and drag to
the right or left
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7. Press F6 to add a keyframe on Frame 6 of each layer you selected. Inserting a keyframe will copy
the artwork from Frame 1 of each layer in the Timeline. This will serve as the ending keyframe of your
shape tween animation.

8. Move the Playhead back to Frame 1. In the following steps, you will be altering the size of each
shape in Frame 1, to serve as the beginning point of the shape tween animation.

9. In the Timeline, click the Lock icon, next to the small Eye icon, to lock all the layers at once. Click
the Lock icon for the left bottom layer to unlock just that layer. This makes it much easier to work on
just the shapes on the left bottom layer without affecting any of the other shapes.

Lock icon
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10. Click on Frame 1 on the left bottom layer to select it. In the Toolbox, select the Free Transform
tool, and then click and drag the upper right resize handle toward the lower left portion of the Stage.
This will scale the shape down to create the starting point of the animation for the left bottom layer.

Free Transform tool
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11. Click on the dot in the Lock column on the left bottom layer to lock that layer. Then click on the
Lock icon for the left top layer to unlock that layer. You will be altering the size of the shape on this
layer next.

12. Click on Frame 1 on the left top layer to select it. In the Toolbox, select the Free Transform tool,
and then click and drag the lower right resize handle toward the upper left of the Stage, just as you
see in the picture above. This will scale the shape down to create the starting point for the animation 
in the left top layer.
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13. Repeat steps 11 and 12 for the middle, right top, and right bottom layers. When you are finished,
the shapes on all the layers on Frame 1 should look like the image above. You may need to use the
Arrow tool to reposition the middle shape near the center of the Stage.

To animate the shapes, all you have left to do is to add a shape tween to each layer. You can add
shape tweens to multiple layers at one time, as you will see next.
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14. Unlock all the layers in the Timeline. Starting with the layer named left bottom, click and drag down
between the two keyframes to select all the layers below the left bottom layer, as shown above.

15. Make sure the Property Inspector is open. If it is not, choose Window > Properties. Select
Shape from the Tween drop-down menu. This will automatically generate a shape tween between
each of the two keyframes on all the layers.

16. Press the Enter/Return key to see the shape tweens in action! By using a multiple shape tween,
you can have different animations on different layers all happening at the same time.

You are almost done! All you have left to do is to put your shape tween layers into a Layer Folder
layer and you will learn how to do this next.

Layers are unlocked
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17. Double-click on the Layer 1 icon. This opens the Layer Properties dialog box. For the Name, type
container and for the Type, select Folder. This changes Layer 1 into a Layer Folder and names the
folder container. Click OK. A chart describing all the layer properties found in this dialog box is provided
at the end of this exercise.

NOTE | What Is a Layer Folder?

A Layer Folder is a special kind of layer that can hold other layers inside of it. It is important to
note that you cannot have artwork in a Layer Folder—the Layer Folder’s sole purpose is to hold
multiple layers so that you can keep your Timeline compact and organized.

Layer icon Layer name

Folder
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18. In the Timeline, click on the right top layer name to select that layer, and then Shift+click on the
left bottom layer name to select that layer and all of the layers in between. With all the layers selected,
drag the layers onto the container layer. This will place all the layers in the Layer Folder. After you do
this, notice that the layers are all indented under the Layer Folder.

19. Click on the arrow to the left of the container layer name to collapse the folder. Now you see the
layers, now you don’t! This is organization! You will really come to appreciate this feature when you
work on projects that have tons of layers.

20. Press Enter/Return to preview your multiple shape tween animation again. Although you’ve
moved the layers into a Layer Folder, the animation is left untouched.

21. When you are finished, save and close this file.

Layer Folder expanded Layer Folder collapsed
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Layer Properties Defined

The Timeline offers a number of ways of controlling layers, but other options are available in the 
Layer Properties dialog box that aren’t visible in the Timeline. The following chart covers these 
additional options.

Layer Properties

Option Description

Guide This option enables you to use the contents of a layer as a tracing image (or
guide), which helps you create artwork on other layers. Guide layers are the only
layers that are not exported with the movie. You will work with a Guide layer in
Chapter 7, “Motion Tweening.”

Guided A Guided layer is a layer that is linked to a Guide layer. The artwork on this layer
can follow the path of the Guide layer it is linked to. Chapter 7, “Motion Tweening,”
will give you hands-on experience working with Guided layers.

Mask Selecting this option will turn the layer into a Mask layer. You will learn more
about this layer type in Chapter 8, “Bitmaps.”

Masked Selecting this option will cause the layer to be masked by the Mask layer above it.
You will learn how to work with this option as well in Chapter 8, “Bitmaps.”

continues on next page
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Layer Properties continued

Option Description

Folder Choosing this option will turn the layer into a Layer Folder so that you can organize
your layers.

Outline Color This option specifies the color that will be used if you select the “View layer as
outlines” option. By default, each layer will have a different color. This just gives
you an extra bit of organizational control.

Layer Height This option makes a layer’s Timeline display “taller” when you increase the line
height of a specific layer. You can choose 100% (the default), 200%, or 300%.
This feature is especially useful for working with sounds on the Main Timeline.
Allowing the layer containing the sound to be taller makes it easier to work with 
the waveforms and to synchronize the sound with your animation. You will try this
later in Chapter 13, “Sound.”
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Animating Gradients

Shape tweening can be used to create additional effects besides morphing one shape into another.
You can also use the shape tween process to animate gradients. This can produce dramatic lighting
effects, such as glows and strobes. In this exercise, you will learn how to modify and animate a gradient.

4.

1. Open the animatedGradientFinal.fla file from the chap_05 folder.

2. Press Enter/Return to preview the animation. Notice that the gradient appears to move
from left to right. This is a finished version of the animated gradient effect you will create in
the following steps.

3. Close the animatedGradientFinal.fla file and open the animatedGradient.fla file from the
chap_05 folder. This file contains two layers: one with the dot on it, which is locked, and one
named text, which is where you will create the gradient tween.



5. Shape Tweening | Macromedia Flash MX H•O•T

| 172 |

4. Click on Frame 1 of the text layer to select the artwork in that frame. It contains text that has been
broken apart so that you can apply a gradient fill to it.

TIP | Why Is the Text Broken Apart?

The text in this exercise file was broken apart because you can’t apply a gradient to text, but you
can apply a gradient to a shape. In order to re-create the animation of the gradient moving from
one side of the word to the other, you have to work with shapes, so the text was broken apart for
you ahead of time.
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5. Make sure the Color Mixer panel is open. If it’s not, choose Window > Color Mixer. With Frame 1
in the text layer still selected, click on the Fill Color box to open the Fill Color palette. At the very
bottom of this palette are some gradients. Choose the black and white radial gradient; it is second
from the left.

As soon as you select the black and white radial gradient, the letter shapes on the Stage will change
to reflect the new gradient fill color because they were already selected. You can click anywhere away
from the Stage to deselect the shapes and see the gradient fill better. To create the effect of the gradient
moving from one side of the word to the other, you will change the center of the gradient next.

6. Click on Frame 1 of the text layer to select all the shapes again.

Fill Color box
with current fill
color showing
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7. In the Toolbox, select the Paint Bucket tool and click in the top left corner of the letter X, as shown
above. The spot where you click defines the center of the radial gradient. Because the radial gradient
is white in the center and black on the outside, the place where you click is where the white point of
the gradient will be.

8. On the text layer, press F6 on Frame 30 in the Timeline to add a new keyframe to the frame. 
As you might remember from Chapter 4, “Animation Basics,” pressing F6 copies the content from 
the previous keyframe and places it on the new keyframe. This can save you from having to re-create
entire pieces of artwork, and it’s especially useful when you want to make only minor changes.

9. On the dot layer, press F5 on Frame 30 to add frames up to Frame 30 on this layer. This will allow
the dot to be visible through Frame 30.

Tip: Even though the dot layer is locked, you can still add and delete frames in the Timeline—you just
can’t select the artwork or objects on the Stage in a locked layer.
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10. Click on Frame 30 in the text layer to select it. In the Toolbox, make sure the Paint Bucket
tool is still selected, and this time click on the top right of the letter m, as shown above. Now it
appears as though a light source is coming from the opposite side of the word. This is the ending
frame of your animation.

11. On the text layer, click anywhere between the two keyframes.

12. In the Property Inspector, choose Shape from the Tween drop-down menu to create a shape
tween between the two keyframes.

13. Press Enter/Return to test your shape tween. Now it looks as though the word “xboarding.com”
is being lit by a moving light source.

Don’t be deceived by the word “shape” in “shape tweening.” As you’ve just seen, shape tweens can
be used to create animations that don’t involve changing one shape into another. In this example,
shape tweening was used to animate a gradient.

14. When you are finished, save and close this file—you won’t be needing it anymore.

I hope this chapter uncovered the many secrets and nuances of shape tweening. You started with the
simple concepts, using simple exercises, and then progressed quickly to a fairly advanced level with
the multiple shape tweening and animated gradient exercises. As you gain experience in Macromedia
Flash MX, shape tweening will likely become a technique you use often for many different types of
effects. If you have the stamina, keep pressing forward to the next chapter. There’s no rush though;
the book will still be here tomorrow.


