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Macromedia Flash MX has a reputation as a
powerful and robust animation tool. If you

know other animation tools, such as
Macromedia Director or Adobe After

Effects, you might find yourself looking
for similarities. It might surprise you
that it’s actually easier to learn the
animation capabilities of Macromedia
Flash MX if you don’t know other
animation programs, because you
have no preconceived notions of
how you think it might work. If
you’ve never used an animation tool
before, you have an advantage over
more experienced animators for this

reason! This chapter introduces you
to the Timeline, which plays a signifi-

cant role in producing animation. This 
is the part of the interface where you 

will work with keyframes, blank keyframes,
frame-by-frame animation, and Onion

Skinning. If these are new terms to you, they
won’t be for long! This chapter also covers setting

the frame rate and how the frame rate affects play-
back speeds. By the end of this chapter, things should

really get moving for you, all puns intended!

4.
Animation Basics

| Timeline | Projects and Movies | Document Properties |

| Frame Types | Frame-by-Frame Animation | Onion Skinning |

| Free Transform Tool | Frame Rate | Inserting and Deleting Frames |

| Copying and Reversing Frames | Testing Movies |

chap_04

Macromedia Flash MX
H•O•T CD-ROM
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The Timeline

Understanding and working with the Timeline is essential to creating animation in Macromedia Flash
MX. The illustration above identifies the elements of the Timeline that you will be working with in this
chapter. In Chapter 5, “Shape Tweening,” you will learn all about the options in the Layers section of
the Timeline. The following chart gives a detailed description of the features identified above.

PlayheadKeyframe Blank keyframe

Layer Frame RateCurrent frame Elapsed time

Frame View

Timeline Features

Feature Description

Layers Layers are a way of organizing the elements of your animation from front to
back on the Stage, so that one object can move in front of or behind another
or can make transitions that are independent of other objects. The Layer con-
trols for your movie appear on the left side of the Timeline. Each layer has
options for hiding or showing the layer, locking it, and displaying its contents
as outlines. You will learn more about layers in Chapter 5, “Shape Tweening.”

Current frame Displays the current position of the Playhead and the frame number of the
frame that is currently visible.

Frame Rate Displays the number of frames per second (or fps) at which the movie attempts
to play on your end user’s browser or computer. Double-clicking here is a quick
way to access the Document Properties dialog box.

Elapsed time Displays time elapsed from Frame 1 to the current Playhead location at the
currently selected frame rate.

continues on next page
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Timeline Features continued

Feature Description

Frame View This pop-up menu gives you several different options for specifying how the
Timeline is displayed. Use it if you want to see fewer or more frames on the
Timeline. The default view is usually just fine until you start creating a longer
animation. At that point, it’s great to be able to see more frames as you work.

Blank keyframe Blank keyframes are empty locations on the Timeline that are ready to have
content placed into them. They can also be used to break up or make
changes in your animation.

Keyframe Keyframes define the moment in the Timeline when actions or animation
changes occur. Keyframe content display remains unchanged until another
keyframe or a blank keyframe occurs in the Timeline.

Playhead The Playhead—a red rectangle with a long red line—indicates the current
frame that you are viewing in the Timeline. You can click and drag (scrub) 
the Playhead back and forth in the Timeline to quickly preview your animation.
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Projects and Movies
In Macromedia Flash MX, the term “movie” can be used to refer to three separate files—the authoring
project file (with the extension .fla), the Macromedia Flash MX content file that is published for the
Internet (with the extension .swf), and the content published as a stand-alone file (projector). All of
these different types of movies can become rather confusing when you are learning Macromedia Flash
MX. To help avoid this confusion, I will be using the terms project to identify the .fla file, movie to iden-
tify the .swf file, and projector to identify the projector files. A more comprehensive explanation of
these different file types is available in Chapter 1, “Background Information.” Here’s a handy chart that
illustrates the differences between these different types of files:

File Types

Icon File Type Description

Project This file always has an extension of .fla and 
is the master authoring file used to create
Macromedia Flash content.

Movie This file always has an extension of .swf and
is the only file you will upload to be viewed
on the Internet. It is a compiled version of the
project file.

Windows Projector Macromedia Flash MX can produce stand-
Macintosh Projector alone projector files for the Windows and 

Macintosh operating systems. Windows 
projector files have an extension of .exe. 
Macintosh projector files have the word 
“Projector” appended to the end of the 
file name.
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Document Properties

The Document Properties are general specifications that affect your entire project. The first thing you
should do when you start a new project in Macromedia Flash MX is to set these properties, which
include things such as Stage dimensions, frame rate, and background color. This exercise will show
you how to set them.

1.

1. Copy the chap_04 folder, located on the H•O•T CD-ROM, to your hard drive. You need to
have this folder on your hard drive in order to save files inside it.

2. Create a new file and save it as movie.fla in the chap_04 folder.

3. The Property Inspector should be visible near the bottom of the document window. If it is
not visible, choose Window > Properties to open it.

By default, the Stage dimensions will be 550 × 400 pixels, the movie will have a white
background, and the frame rate will be 12 frames per second. You’ll learn how to change
each of these settings in the steps that follow.

4. In the Property Inspector, set the Frame Rate to 22. This sets the frame rate of your
movie to 22 frames per second (fps). In other words, for every 22 frames in your animation, 
1 second of time will elapse. You will learn more about the frame rate later in this chapter.
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5. In the Property Inspector, click the Background Color box. This will display the default color
palette. Select a light blue color. This will change the background color of your movie to light blue.

6. With the Property Inspector still open, click on the Size button. This will open the Document
Properties dialog box, which contains all the frame rate preferences, movie dimensions, background
color, and rule measurements that you can set for your entire movie.

7. In the Document Properties dialog box, for the Dimensions settings, enter a width of 700 and a
height of 350. These options control the absolute pixel dimensions of your Stage. You will learn other
ways to control the size of your movie when you get to Chapter 16, “Publishing.”



4.Animation Basics | Macromedia Flash MX H•O•T

| 104 |

8. Click the Ruler Units arrow to see the drop-down menu. This menu contains several different 
methods for displaying the ruler units on your Stage. Make sure you leave this option set to the 
default of Pixels.

9. Click OK. Notice that  the values in the Property Inspector—the dimensions, background color, and
frame rate—are changed to your new specifications.

You can quickly use the Property Inspector at any point to change the movie’s background color or
frame rate. In addition, you can use the Size button in the Property Inspector to access the Document
Properties dialog box, where you can change the options not available in the Property Inspector.
However, you should avoid changing the dimensions of your movie once you have added content to
your Stage. The reason for this is that changing the dimensions once you’ve started creating artwork
and animation causes the position of all your hard work to be offset, which can be difficult to fix.

10. When you are finished, save the changes you made to this file. However, don’t close it just yet;
you will need it for the next exercise.
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What Is a Keyframe?
The term keyframe has been used in animation since the early 1900s. It signifies a change in motion,
and in Macromedia Flash MX, keyframes are displayed on the Timeline. The Timeline represents the
passing of time, with each slot representing an individual frame. If you have artwork in Frame 1 and you
don’t change it until Frame 20, the image in Frame 1 will persist until Frame 20. You would need to add
a new keyframe in Frame 20 in order to make a change to the artwork. If you have artwork in Frame 1
and you want to change it in Frame 2, you would need to add a new keyframe in Frame 2; therefore,
you would end up with two keyframes, one in Frame 1 and the other in Frame 2.

This concept might seem abstract to you if you’ve never worked with keyframes before, but you will
have lots of opportunities to work with keyframes in this chapter, so they won’t be alien to you for long.

TIP | Saving New Default Settings

When you create a new movie, by default you will get a Stage that is 550 × 400 pixels with a
white background. This size might not be all that convenient when you are working on projects
that should have different settings. But there’s good news—you can redefine the default settings
so they better fit your needs. Simply change the Document Properties to match the settings you
need and click the Make Default button. Next time you create a new movie, it will already have 
all the properties you want. Pretty cool!
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Keyframes in Macromedia Flash MX

Keyframes are located in the Timeline. A keyframe that contains content displays a solid circle in 
the Timeline, and a blank keyframe that contains no content on the Stage is represented by a hollow
circle in the Timeline. Subsequent frames that you add to the same layer will have the same content 
as the keyframe.

To complicate things a little more, Macromedia Flash MX has different kinds of frames and keyframes.
The following chart describes the different types and gives the keyboard shortcut for each in parentheses.

Blank Keyframe
with Actions

Blank Keyframe
with SoundKeyframe

Blank
Keyframe

Frame Types

Term Definition

Blank keyframe (F7) A blank or empty keyframe is represented by a hollow circle. It means
that there is no artwork on the Stage on that frame. The Timeline, by
default, opens with a blank keyframe. As soon as you put content on
the Stage, the blank keyframe changes to a keyframe. From that point
on, this artwork will be copied to all frames until you define another
keyframe or blank keyframe and change the content on the Stage at
that frame. To confuse matters a little more, although a blank keyframe
contains no artwork, it can contain sound and actions. You will learn
more about sound in Chapter 13, “Sound,” and more about actions in
Chapter 11, “ActionScripting Basics.”

continues on next page
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Frame Types continued

Term Definition

Keyframe (F6) A keyframe that contains content (meaning that artwork is on the 
Stage at that frame in the Timeline) is represented by a solid circle. 
By default, when you add a keyframe in Macromedia Flash MX, the
content (except for actions and sounds) is copied from the previous
keyframe. To make a change, you must alter the artwork on the Stage 
at the point on the Timeline where you have defined the new keyframe.
Otherwise, Macromedia Flash MX will simply copy the content from the
previous change. In other words, simply adding a keyframe will not
cause the artwork to change.

Frame (F5) The Timeline in Macromedia Flash MX looks as though it has lots 
of frames in each layer, which can be a bit deceiving! While it has 
slots for frames, you have to specifically define them as frames (or
keyframes, etc.). You can do this by clicking in any of the slots and
pressing F5 or by choosing Insert > Frame. It’s possible to have a
different number of frames on different layers. For example, Layer 1
could have 10 frames while Layer 2 has one frame. It is up to you to 
set the frames for each layer.

Clear Keyframe To clear the content from a keyframe, you use the Clear Keyframe 
(Shift+F6) command. You do this when you want to erase the keyframe from the

Timeline. Clearing a keyframe removes the content from the keyframe
but leaves the frame. This will not reduce the number of frames on a
layer but will simply remove the keyframe and change it to a regular
frame. This command is usually used to fix (or clear) a mistake.

Remove Frames If you ever want to delete frames that you have set, select those frames 
(Shift+F5) and press Shift+F5 or choose Insert > Remove Frames.
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Frame-by-Frame Animation with Keyframes

This exercise will teach you how to work with keyframes. A common animation technique is to make a
word appear as though it is being written before your eyes. This is very simple to do using keyframes,
because when you insert a keyframe, the program searches backward in the Timeline until it finds another
keyframe and then copies that content to the newly inserted keyframe. You will learn how to make a word
appear in the following steps.

2.

1. Open the movieFinal.fla file from the chap_04 folder. This file has been created for you so
that you can see the finished version of the exercise.

2. Press Enter/Return on the keyboard to preview the animation on the Stage. You will
notice the word “Xboarding” being written right on the screen as it animates. You will be
creating this same frame-by-frame animation next.

WARNING | Windows Users

If you don’t see a file named movieFinal.fla but you do see a file named movieFinal,
your file extension display may be turned off on your computer. To learn how to make 
the file extension visible, see the Introduction.
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3. Close the movieFinal.fla file.

4. You should still have the movie.fla file open from the last exercise, but in case you accidentally closed
it, go ahead and open the movie.fla file you saved inside the chap_04 folder in the last exercise.

Notice that this document has a single layer containing a single blank keyframe. This is the way all
new documents appear by default. Every project has to have a starting point, and this is the minimum
you need to start drawing. The blank keyframe has a hollow circle and a line around the frame.

5. Select the Brush tool from the Toolbox. You can use any size, shape, and color (other than white—
you will see why in step 11) you want. You are going to be writing the word “Xboarding,” one letter at 
a time, in a series of keyframes.

Blank layer Blank keyframe
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6. Using the Brush tool, draw the first part of the capital letter X on the left side of the Stage, as
shown in the picture above. Notice that the blank keyframe in Frame 1 now contains a small black 
dot, which signifies that it contains content. Frame 1 is now referred to as a keyframe because it is 
no longer empty.

To make a change on the Timeline, you must have a keyframe where you want the change to occur.
Now that you have filled in the first keyframe of Layer 1, you are going to add another keyframe after
it so you can draw the second frame of your animation. Adding a new keyframe after the last one will
copy all the content from the last keyframe to this new keyframe. You will draw another stroke in this
new keyframe in order to create a change in your animation.

7. Select Frame 2 and choose Insert > Keyframe or press F6 (the shortcut key). This adds a 
new keyframe to the Timeline in Frame 2, copying all the artwork in Frame 1 and allowing you to 
continue drawing.

Tip: F6 is a keyboard shortcut you should learn right away, because you will be using it often to
insert keyframes.

Keyframe

Content
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8. Using the Brush tool again, draw the second part of a capital X in the new keyframe, just like the
picture above.

9. Press F6.This adds a new keyframe to the Timeline in Frame 3, copying all the artwork from the
previous keyframe, Frame 2.

10. Now draw a b just like the picture above. Believe it or not, you have already created the beginning
of your animation! You can click and drag (scrub) the Playhead back and forth in the Timeline to quickly
preview the animation. You will see the “X” and the “b” being drawn directly on the Stage.

Playhead

Content in Frame 3
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Looking at a Timeline with a bunch of black dots might seem somewhat abstract to you. The Frame
View menu has several options that allow you to display the contents of your individual frames right
in the Timeline.

11. From the Frame View drop-down menu, select Preview. This will change your Timeline so that you
see a preview of what is on each frame instead of a bunch of black dots. I find this view of the Timeline
very helpful when creating frame-by-frame animations.

Note: If you had chosen white for the Brush color, you would not see the artwork in Preview mode
since the Timeline frames are white also.

12. Press F6 to insert another keyframe so you can continue to draw the pieces to spell out the word
“Xboarding.”

Frame View menu

Timeline in Preview mode
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13. Using the Brush tool, draw an o on the Stage. You should be able to see the contents of your
fourth frame appear in the Timeline preview.

As you continue to spell out the word “Xboarding,” you don’t have to draw the whole letter in each
keyframe. Instead, you can draw a part of the letter (just as you did with the “X”) in one keyframe,
press F6 to insert the next keyframe, and draw the remaining parts of the letter in that keyframe for 
a more realistic drawing animation.

14. Go ahead and continue to spell out the word “Xboarding” by pressing F6 to add a new keyframe
after the previous one and then adding more letters or parts of the letters in each one, using the Brush
tool. When you are done, your Timeline should look like the one shown above.

You can get a quick preview of your animation right away using one of two methods. You can scrub
the Playhead across the Timeline as mentioned in step 10, or you can press Enter/Return and watch
the animation play directly on the Stage. So get out the popcorn and watch your first animation!

15. Press Enter/Return. Your animation will play once on the Stage and stop at the last keyframe.
Unlike scrubbing the Playhead, this time you are seeing an accurate preview of the frame rate for 
this movie, which you set in the previous exercise: 22 fps. (Frame rate is covered in more detail later 
in this chapter.) Press Enter/Return to preview the animation again as many times as you like.

There are other ways to preview your animations that will be covered later. For now, this exercise is
focused on the basics.

16. Save and close this file.
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Onion Skinning

In the last exercise, you learned to work with keyframes and to add content to each new keyframe you
inserted in the Timeline. This exercise will teach you a few new techniques. First, you’ll learn to use the
Onion Skinning feature. This feature allows you to see a ghost image of the previous frame so you
can see where you want to place the artwork on each frame in relation to the frames before it. Next
you will learn to use the new Free Transform tool to modify the artwork. This exercise will also teach
you how to use a feature called Loop Playback, so you can preview your animation over and over until
you get sick of it. Just kidding!

3.

1. Open onionFinal.fla file from the chap_04 folder. This file has been created for you so
that you can see the finished version of the exercise.

2. Before you preview the animation, choose Control > Loop Playback. This will allow you 
to see the animation repeat over and over when you preview it.

3. Press Enter/Return on the keyboard to preview the animation on the Stage. You will see
the snowboarder catching some air! In the following steps, you will be creating this same
animation technique. To stop the looping, choose Control > Loop Playback again.



Macromedia Flash MX H•O•T | 4.Animation Basics

| 115 |

4. Close the onionFinal.fla file.

5. Open the onion.fla file from the chap_04 folder. This file contains one keyframe with the snow-
boarder beginning his jump on the top layer and one keyframe with the snow on another layer. The
layer named snow has been locked so that you don’t accidentally select something on that layer. 
You will be altering only the artwork on the snowboarder layer in the next few steps.

6. Select Frame 2 and press F6 to add a keyframe to the frame. Notice that Frame 2 is now a keyframe
because it contains a small black dot, which signifies that it contains content.

If you press F6 without first selecting the frame where you want to add a keyframe, nothing happens.
Why? When you have more than one layer in your document, you have to select the frame first in
order for Macromedia Flash MX to know where you want to place the keyframe.
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7. In Frame 2, click on the snowboarder artwork to select it, and move it up and to the right, as though
he is advancing in his jump.

8. At the bottom of the Timeline is a row of five buttons. Click the second button from the left. This 
is the Onion Skin button. You will be able to see a faint ghost image of the content in Frame 1 on 
the Stage. This convenient feature allows you to see the artwork in the previous keyframes and change
the artwork relative to the ghost images.

Frame 1 content

Frame 2 content
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9. With Onion Skinning turned on, select the new Free Transform tool in the Toolbox. This tool
allows you to modify your artwork by changing the size, rotation, skew, and distortion of the selected
artwork. The chart at the end of this exercise illustrates the functions of the Free Transform tool.

NOTE | Onion Skin Markers

After you click the Onion Skin button, a gray bar with a draggable bracket on each end appears
at the top of the Timeline. These are called Onion Skin markers. The Start Onion Skin marker
(the one on the left) is on Frame 1 (the start of your animation), and the End Onion Skin marker
(the one on the right) is on Frame 5 (the last frame of your animation). If you click and drag your
Playhead to the right or left and let go, the Start Onion Skin marker will move. Basically, Onion
Skinning will move along with your Playhead. You can always drag one of the Onion Skin markers
to include more frames if it is spanning fewer keyframes than you have in the Timeline.

Onion Skin markers
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10. With the Free Transform tool selected, click on the snowboarder in Frame 2 to select the shape,
if it is not already selected. Notice the bounding box that appears around the artwork. This box indicates
that you can transform the artwork.

If you move the cursor over different parts of the selected artwork, the cursor will change to indicate
what transformation function is available.

11. Move your cursor just outside the upper right corner of the bounding box until it changes to a
round arrow, as shown in the picture above. This icon indicates that you can rotate the artwork. Click
and drag to the right to rotate the snowboarder a bit and make the jump look more realistic.

12. Select Frame 3 and press F6 to insert another keyframe so you can create the third frame of 
your animation.
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13. With Onion Skinning still turned on, select the snowboarder artwork in Frame 3 and move it to the
right. Select the Free Transform tool and rotate the snowboarder again, just as you did in step 11.

14. Finish off the snowboarder jump by repeating steps 12 and 13 twice more, adding two more
keyframes to Frames 4 and 5 and modifying the artwork in each keyframe.

15. Choose Control > Loop Playback so that you can see the animation repeat over and over.



4.Animation Basics | Macromedia Flash MX H•O•T

| 120 |

16. Press Enter/Return to test the movie. You will see the snowboarder catching some air!

If you do not want the Onion Skin markers to move when you move the Playhead or click on a frame
in the Timeline, you can choose Anchor Onion from the menu that appears when you click the Modify
Onion Markers button at the bottom of the Timeline. This will lock the Onion Skinning span where it
is until you unlock it again or manually drag the Start or End Onion Skin markers.

17. You will have the chance to work with the other features of the Free Transform tool in Chapter 6,
“Symbols and Instances.” For now, save and close this file.

Modify Onion
markers
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NOTE | The Free Transform Tool

You can use the Free Transform tool to modify objects in several ways. As you move the cursor
over the bounding box around a selected object, it will change to indicate what type of transfor-
mation is available to you. As you drag, you will see a preview of the transformation you are about
to make. The chart below lists the features of the Free Transform tool.

Free Transform Tool Functions

Clicking and dragging up or down on a corner transform handle
will rotate the object. The cursor icon will change to a round arrow,
as shown in the image at left. This arrow indicates that you can
rotate the object.

Clicking and dragging diagonally on one of the corner transform
handles will modify the scale of the object. The cursor icon will
change to a diagonal double-pointed arrow when you can perform
this transformation.

Clicking and dragging on one of the middle side transform
handles will modify the width or height of the object. The 
cursor icon will change to a horizontal (or vertical depending 
on which side you are on) double-pointed arrow when you 
can perform this transformation.

Clicking and dragging between any two transform handles will
skew the object. The cursor icon will change as shown at left. 
This icon indicates that you can skew the object.

Clicking and dragging one of the middle side transform handles 
to the other side of the object will flip the object. The cursor will
change to a horizontal or vertical double-pointed arrow depending
on which side you are on.

Clicking and dragging the center registration point will modify 
the center point of the object. After you alter the center point, all
transformations will rotate or move in relation to the new center
point location.
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Understanding Frame Rate

Now that you have created a couple of frame-by-frame animations, it’s time to investigate the Frame
Rate setting of your movie. The frame rate defines how many frames your animation will try to play 
in one second. I use the word “try” because there is no guarantee that your movie will play back at 
the specified frame rate, due to the varying processor speeds of the computers that your end users
might use. In the following steps, you will start by opening a file that contains a simple frame-by-frame
animation of a snowboarder moving down a mountain. You will test the animation to preview the
current frame rate and then lower the frame rate to see the impact it has on playback speed.

4.

1. Open the properties.fla file located inside the chap_04 folder. This file contains one layer
with a frame-by-frame animation of a snowboarder cruising down a mountain.
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2. Press Enter/Return to watch the animation play on the Stage. The animation will play at the default
frame rate of 12 fps.

3. Make sure the Property Inspector panel is open. If it is not, choose Window > Properties or press
Ctrl+F3 (Windows) or Cmd+F3 (Mac) to open it.

4. In the Frame Rate field, enter 6. This will lower the frame rate to 6 frames per second, reducing the
speed of the animation by half.

5. Press Enter/Return. Notice that the animation plays much more slowly and kind of stutters. You are
taking twice the time to play the same number of frames. The lower the frame rate, the slower the ani-
mation will play.

6. Save and close this file; you won’t need it for the next exercise.
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What Is the Frame Rate?
The frame rate determines the number of frame your movie plays per second. This rate corresponds
directly to the length of time your animation takes to play.

Here’s how to use the frame rate to calculate the playback time of your animation. Take the total num-
ber of frames in your Timeline and divide that by the frame rate; the result is the number of seconds it
will take to view your movie.

For example, if your Timeline has 10 frames and your frame rate is set to 6 FPS (frames per second),
your animation will display in 1.67 seconds. The chart below gives several examples of how the frame
rate affects the length of time an animation takes to play.

Number of Frames / Frame Rate = Time

24 frames / 12 fps = 2 seconds

36 frames / 12 fps = 3 seconds

48 frames / 24 fps = 2 seconds

72 frames / 24 fps = 3 seconds

Number of frames Frame Rate

It is important to note that the frame rate affects all of the animations in your movie. In the next exercise
you will learn how to make animations play at different speeds in the same Timeline.
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Recommended Frame Rates
When you set a frame rate in Macromedia Flash MX, you’ve set the maximum frame rate for your movie,
or how quickly the movie “tries” to play. The actual playback frame rate depends upon several factors,
including download speed and the processor speed of the computer viewing the movie. If the frame
rate is set higher than the computer can display, the movie will play as fast as its processor will allow.
So if you set your frame rate to 200 (which is really high), the average computer will not display the
movie at that rate. Here’s another wrinkle: Frames that have more objects, colors, or transparency than
others take more time for the computer to render. Thus, the actual frame rate can vary during playback
due to the rendering requirements from one frame to another.

Based on all this information, I would recommend that you use a frame rate of at least 12 fps and not
more than 25 fps, so that the average computer can display your movie as you intended. A frame rate
of 20 to 22 fps seems to work well most of the time. This rate is very similar to that used in motion
pictures, which typically play at a frame rate of 24 frames per second.
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Inserting and Deleting Frames

As you learn to create frame-by-frame animation and other types of animation, you will at some point
want to adjust their speed. In the previous exercise, you learned that adjusting the frame rate will do
just that, but it affects the entire movie. That might not be what you want to do, so in this exercise, you
will learn how adding and removing frames in your Timeline can help control the timing of your animation.
This means that you can have multiple animations playing at different tempos, even though they all
share the same frame rate.

5.

1. Open the frames.fla file from the chap_04 folder. This file contains a simple frame-by-
frame animation with some text. You’ll be learning more about how to use text in Chapter 12,
“Working with Text.”
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2. Press Enter/Return to preview the animation on the Stage. The animation will play pretty quickly. 
In fact, it’s playing so fast that you almost lose the effect of the text appearing one letter at a time.

If you adjust the frame rate to slow down this animation, it will also affect every other animation in
this project. This could cause some serious problems if you wanted other sections of your movie to
play at a different speed. So you must find another way to slow down the animation. One way to do
this is by inserting frames at strategic points to lengthen parts of the animation. That’s exactly what
the following steps will show you how to do.

3. Click in Frame 1 of Layer 1, and choose Insert > Frame or use the shortcut key F5. This will insert
a frame between Frames 1 and 2, extending the Timeline by one frame.

4. Press F5 to insert another frame. Each time you choose Insert > Frame or press F5, you will insert
one frame and extend the Timeline.
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5. Press F5 again so that you have a total of three additional frames between your first two keyframes.
By extending the space between the first two keyframes in the Timeline, you are able to control the
timing of the animation, as your image will display for a longer period of time.

TIP | What Do Those Dots Mean?

As you start adding content to your Timeline, you will notice different icons appearing in your
Timeline. The black dots indicate keyframes. The light gray frames after the keyframe indicate no
change in content. The small white square inside a light gray frame indicates the ending point of 
a frame range, which also means that the next frame will be a blank keyframe or a keyframe. The
white frame with a hollow circle, directly after the frame with a hollow square, is a blank keyframe.

Final frame
before changeKeyframe

Blank
keyframe
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6. Press Enter/Return to preview the animation on the Stage. Now there is a noticeable delay
between the letters “s” and “n.”

7. Click in Frame 5 of the Timeline. This is where the second keyframe should be located.

8. Press F5 three times to insert three frames in the Timeline. This will create a short pause between
the letters “n” and “o.”
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9. Repeat this process for the other letters in the animation. When you are finished, your Timeline
should look like the one shown above.

10. Press Enter/Return to preview your animation on the Stage. See how much slower the entire
animation plays—and you didn’t have to touch the frame rate for the movie. Nice.

Great—you now know that you can control the timing of individual animations without having to adjust
the frame rate of your entire movie. You have just seen that by inserting frames you can slow down
an animation, so it should be no surprise that you can increase the timing of the animation by delet-
ing frames. You will learn how to do this next.
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11. Click on Frame 2 of the Timeline and choose Insert > Remove Frames. This will remove the
selected frame, shortening your Timeline by one frame and decreasing the amount of time between 
the “s” and “n” letters in your animation.

12. Ctrl+click and drag (Windows) or Cmd+click and drag (Mac) and select Frames 5 and 6. This
lets you select a specific range of frames. Make sure you hold the appropriate key down as you click
and drag; otherwise you might accidentally move keyframes around.

The Timeline is
now shorter by

one frame
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13. With Frames 5 and 6 still selected, choose Insert > Remove Frames. This will remove the
selected frames and shorten your Timeline by two frames.

14. Go ahead and use Shift+F5 (the keyboard shortcut for removing frames) to remove the frames
between each of the keyframes in the Timeline (including the ones between Frames 1 and 4) so that
there is only one frame between every two keyframes. When you’re finished, your Timeline should look
like the one shown above.

15. Press Enter/Return to preview your animation on the Stage. The animation will play much faster
than it did before, because there are fewer frames between the keyframes. Now you know at least two
ways to speed up or slow down the timing of your animation.

16. Save and close this file.
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Copying and Reversing Frames

Creating a looping animation (one that repeats indefinitely) can be a lot of work if you have to draw all
the frames over and over. In Macromedia Flash MX, you can quickly and easily copy, paste, and reverse
a sequence of frames to create a looping animation. You will learn to do this in this exercise.

6.

1. Open the properties.fla file from the chap_04 folder. This is the same file you worked 
on earlier.

2. Using the Property Inspector, make sure the Frame Rate is set back to 12.
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3. Click to the right of the layer name. This is an easy way to select all of the frames on a layer. Before
you can copy a range of frames, you want to make sure you have selected them first.

4. Move your cursor over the selected frames. Click and drag to the right. But don’t release the mouse
button just yet! Note: The light gray outline surrounding the frames indicates where they’ll be moved
when you release the mouse button.

5. While still holding the mouse button down, press the Alt (Windows) or Option (Mac) key. Notice
that a small plus sign appears to the right of the cursor. This indicates that you will duplicate, not move,
the frames when you release the mouse button.

Selected frames
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6. Release the mouse button. This will place a copy of the selected frames in Frames 11 through 20.

7. With Frames 11 through 20 still selected, choose Modify > Frames > Reverse. You won’t see any
noticeable reversal in your Timeline, but you will when you test the movie.

8. Press Enter/Return to preview your animation on the Stage. The snowboarder will race down the
hill and then go backward up the hill, as if you were rewinding the film to view an instant replay! Neat!
If you choose Control > Loop Playback, you can watch the animation preview loop endlessly.

9. Save and close this file.

New frames



4.Animation Basics | Macromedia Flash MX H•O•T

| 136 |

Testing Movies

So far, you’ve been testing your movies by pressing Enter/Return and watching them play on the
Stage. This is a great way to test the frame rate, but there are other ways to test your work. In this
exercise, you will learn how to preview the movie file (.swf) with the Test Movie feature and how to
preview your movie in a browser with the Preview in Browser feature. You will also learn a really easy
way to produce the HTML file needed to hold your .swf file. More in-depth instruction on publishing
Macromedia Flash MX content is provided in Chapter 16, “Publishing and Exporting.”

7.

1. Open the frames.fla file from the chap_04 folder.
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This file should have been saved inside the chap_04 folder. It is important to know where your
project file (.fla) has been saved before you use the Test Movie and Preview in Browser features,
because as you’ll see, Macromedia Flash MX automatically generates new files and saves them 
with your project files when you use these features. If you saved your file in a different location, 
make sure you know where it is.

2. Choose Control > Test Movie. This will open a new window with a preview of the movie file(.swf)
that would be exported if you chose to publish your movie right now.

Tip: You can click on the resize handle of the Preview window and drag to make your window larger.
Although the size of the window will change, the snowboard letters will stay the same size. You will
learn how to make the content scalable, also using the publish settings, in Chapter 16.

Resize handle
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3. With the .swf file still open, choose Window > Toolbars > Controller (Windows) or Window >
Controller (Mac). You’ll see a small toolbar on your screen that looks like the front of your VCR or
other media player. This handy little gadget helps you control the playing of your animation.

4. Click the Stop button. As you probably guessed, this stops your animation.

TIP | Loop-de-loop

At this point, you’re probably wondering why your animation is looping (playing over and over).
This is the default behavior of all movies in Macromedia Flash MX, although you don’t see it when
you simply press Enter/Return to preview your work (unless you’ve set the file to Loop Playback).
If you uploaded your published file to the Web, however, it would loop. You will learn to control
the looping in your final movie (.swf) file in Chapter 11, “ActionScripting Basics,” when you learn
how to add actions to frames. If all this looping is making you dizzy, you can select Control >
Loop to deselect this feature and turn it off temporarily.

Stop button
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5. Click the Play button. Yes, you guessed it; this plays your animation. Go ahead and take a few
minutes to try the other buttons on the Controller.

Something else happened, behind the scenes, when you chose Control > Test Movie. Macromedia
Flash MX automatically created the .swf file for this movie and saved it in the same location as your
project (.fla) file. You’ll locate this file next.

6. Open the chap_04 folder from your desktop. Notice that there is a frames.swf file inside this folder.
This file was automatically generated by Macromedia Flash MX. Also notice that the .swf file has a different
icon than the .fla files. This can be helpful visual feedback, especially if your file extensions are turned
off. The .swf file is the file that you would add to an HTML page, much as you would a .gif or .jpg file.

Stop

Rewind Play

Go To End

Step Back Step Forward
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7. Return to Macromedia Flash MX and close the Preview window.

8. Choose File > Publish Preview > Default – (HTML) or use the shortcut keys Ctrl+F12
(Windows) or Cmd+F12 (Mac). This will launch your default browser with a preview of your movie file
(.swf) inside the browser window. This command provides a quick and easy way to see what your
movie files will look like in a browser. You will learn a more appropriate and formal way of publishing
your Macromedia Flash movies later in Chapter 16, “Publishing and Exporting.”

Again, something extra is happening behind the scenes. When you preview your movie in a browser,
Macromedia Flash MX will automatically create an HTML file, as well as the .swf file if there isn’t one
already, in the same location as the project file (.fla). So make sure you always know where you’re
saving your project files.

NOTE | How Does Macromedia Flash MX Know Which Browser to Use?

If you have several browsers installed on your system, you can specify which one Macromedia
Flash MX uses as the default browser. You can change the default browser to your preferred
browser in a few steps. There’s a great explanation of how to do this for either a Windows
machine or a Macintosh on Macromedia’s Web site: http://www.macromedia.com/support/
flash/ts/documents/browser_pref.htm.
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9. Hide Macromedia Flash MX for a moment and look inside the chap_04 folder on your desktop.
Notice that there is a frames.html file inside this folder. Macromedia Flash MX generated this file
automatically to hold your frames.swf file.

At this point, all the files necessary to publish to the Web have been generated automatically. More
thorough instructions and details are provided in Chapter 16, “Publishing and Exporting.” This exercise
simply demonstrated a quick and easy way to generate files.

10. Return to Macromedia Flash MX and save the changes you made to this file. You can close this
file—you are finished with this chapter! It was a long but essential part of your animation training.

Well, that’s about it for the basic stuff. The next three chapters deal with more complex and specific
issues, such as symbols and instances, motion tweening, and shape tweening. Now would be a great
time for a break—you’ve worked through a lot of material, and you deserve one!


