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Whether you are new to Macromedia Flash or
you are a veteran of previous versions, you

should not skip this chapter. Although you
might be tempted to jump right in and

begin with the hands-on exercises, take
the time to read through this chapter
first so you have a grasp of the new
Macromedia Flash MX interface.

This chapter begins with an
overview of the main components:
the Timeline, Stage, Work Area,
and Toolbox, as well as the new
panels in Macromedia Flash MX.
This will be relatively short so you
can get to the actual exercises as

quickly as possible. After all, that’s
the best way to learn how these tools

work. The overview in this chapter will
make it easier for you to work with the

various elements throughout the rest of 
the book.

2.
Interface

| Document Window | Timeline |

| Layer Controls | Information Bar |

| Toolbox | Panels |

| Custom Keyboard Shortcuts |

no exercise files

Macromedia Flash MX
H•O•T CD-ROM
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The Document Window

The Document Window contains six main elements: the Timeline, the Stage, the Work Area, the
Information Bar, the Toolbox, and, new to Macromedia Flash MX, the panels, including the Property
Inspector panel shown here.

Property Inspector panel

Toolbox Timeline PanelsInformation Bar

Stage
Work
area

Panels
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Each time you create a new document in Macromedia Flash MX, you are presented with a new blank
Document Window. This window is divided into six main components:

Timeline The Timeline is where you control the static and moving elements in the project file, using
layers, the Playhead, frames, and the Status Bar. All are described in detail in the next few pages.

Stage The Stage is where your animation and images appear. It represents the visible area of your
project. You will learn how to modify the properties of the Stage, such as size, color, and frame rate, 
in Chapter 4, “Animation Basics.”

Work Area The light gray area around the Stage is referred to as the Work Area. Nothing in the Work
Area will be visible to the end user after you publish your movie. You can place objects here until you
want them to appear on the Stage. For example, if you want to animate a bird flying in from offstage,
you can place the bird artwork offscreen in the Work Area so it appears to fly in from outside the 
Stage area.

Information Bar The Information Bar displays your current location inside the project file such as the
name of the current scene, a number of buttons that let you edit scenes and symbols, and the Zoom
box. This bar may change location based on whether your Timeline is docked or not. Docking and
undocking the Timeline is discussed later in this chapter.

Toolbox The Toolbox contains tools that are necessary when creating and editing artwork. This long
vertical bar gives you access to just about every tool you will need to create and modify the objects in
your Macromedia Flash MX projects.

Panels Panels are windows that contain tools and information to help you work in your project file
more efficiently. Each of the panels can be used to view and modify elements within your project file.
For example, the Property Inspector panel changes depending on what is selected, and it allows you to
make changes to the current selection quickly, right inside the panel. You will learn more about panels
later in this chapter.
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TIP | The Status Bar

If you’re a Windows user, you can choose Window > Toolbars > Status to extend the bottom 
for your screen to display helpful hints. When the Status option is selected, this area will display 
a description of the tool or menu item that your pointer is over, allowing you to see what it does
before you select it.
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The Timeline

The Timeline controls and displays all of the static and moving elements of your project over time,
using frames and layers. In this section, you’ll learn about the main elements of the Timeline. As 
I cover each of these elements, don’t forget that you will get hands-on experience later as you go
though the exercises.

Playhead The Playhead indicates which Timeline frame is currently displayed on the Stage. Once 
you have artwork on the Stage and have created different frames (which you’ll learn to do in Chapter 3,
“Drawing and Color Tools”), you can click and drag the Playhead to move it to a specific frame. Many
people also scan through the Timeline (a process called scrubbing) to quickly preview animations. 
You will get a lot of practice doing this in the animation portions of this book.

Layer controls This region lets you control the features of the layers, including adding, organizing,
hiding, and locking layers, as well as displaying the content of layers as outlines. Because there are 
so many options here, I will wait until later in this chapter to describe them in more detail.

Status Bar The Status Bar gives you feedback about the current frame, the number of frames per
second (fps), and the elapsed time of your movie. It also controls some animation tools, such as onion
skinning. All of these issues will be addressed fully in Chapter 4, “Animation Basics.”

Frame View This not-so-obvious drop-down menu lets you control the appearance of your Timeline.
You can change the appearance of the individual frames and the entire size of the Timeline itself. As
you will see in Chapter 13, “Sound,” this can be helpful with certain projects.

Playhead

Frame
View

Layer controls Status Bar
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Docking and Undocking the Timeline

If you have the luxury of working with a large monitor or multiple monitors, you will be pleased to know
that you can easily dock and undock the Timeline from the main document window. This feature allows
you more flexibility in arranging your work environment. For example, you can place the Stage on one
monitor and stash all the Macromedia Flash MX panels on your second monitor, giving you an unclut-
tered view of your work. By the way, if you find the ability to undock the Timeline annoying, you can
disable this feature in the Preferences.

Docking and undocking the Timeline can be done in one or two easy steps: Move your cursor over 
the upper left corner of the Timeline until you see a series of dots and the cursor turns into either an
icon with four arrows (Windows) or a Hand icon (Mac). Click and drag in that area (as shown above)
to undock the Timeline. A thin outline will appear when you click, indicating that you have grabbed the
Timeline and are moving it.

Release the mouse button and your Timeline will be undocked from the Document Window and will
appear as its own window. Once it is undocked, you can click in the Timeline header to drag it around.

If you want to redock the Timeline, you can choose from four locations: its default position above the
Stage, the right side of the Document Window, the left side of the Document Window, or the bottom
of the document window. To redock it, simply click in the Timeline header, drag it back to one of the
four locations, and release the mouse button.
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The Layer Controls

Macromedia Flash MX allows you to use layers to organize your artwork, just like other graphics pro-
grams you might be familiar with, such as Macromedia Fireworks, Adobe Photoshop, etc. The Timeline’s
Layer controls play an important role in your workflow. This is where you add, modify, delete, and
organize layers and where you can hide, lock, and control the appearance of the layer contents. As 
you add layers in Macromedia Flash MX, the artwork on the topmost layer in the Timeline will appear
closest to you on the Stage. At any time you can change the stacking order of the artwork simply by
dragging and dropping the layers higher or lower in the Timeline. The following list explains the Layer
controls in detail.

Layer name The default layer names are Layer 1, Layer 2, and so on. Double-click a name to change it.

Insert Layer Adding new layers to your projects is as easy as clicking this button. Each time you click,
a new layer is added on top of the one that is currently selected.

Add Motion Guide This button adds a Guide Layer on top of the currently selected layer. You will
work with Guide Layers in Chapter 7, “Motion Tweening.”

Insert Layer Folder This button is a new feature in Macromedia Flash MX. It adds a special Layer Folder
that can hold other layers. This is helpful in organizing your layers into groups that can be easily expanded
and collapsed.

Delete Layer There’s not much mystery to this trash can button. Clicking this button deletes the layer
that is currently selected. Don’t worry, though: If you click this button by accident, you can undo it by
choosing Edit > Undo. Phew!!

Show/Hide All Layers Clicking the Eye icon will temporarily hide the artwork on the Stage and Work
Area on all layers in the Timeline. Note: This will not hide your artwork in the published movie.

Layer name

Insert Layer

Show/Hide All Layers Lock/Unlock All Layers

Outline View

Delete Layer

Add Motion Guide Insert Layer Folder
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Lock/Unlock All Layers Clicking the Padlock icon to lock the layer makes it impossible to edit any-
thing on this layer. This control can be useful when you start working with multiple layers, especially
ones with overlapping content.

Outline View Clicking this icon displays all of the contents of all of the layers in the Timeline in
Outline view, in which solid shapes are represented as outlined shapes with no solid fill. This feature
can be very helpful when you are working with multiple layers with overlapping content.

The Information Bar

The Information Bar is very useful for quick visual feedback as to where you are located in your movie.
It contains buttons and a drop-down menu that give you quick access to the scenes and available zoom
levels. Here is a brief description of each feature in the Information Bar.

Current Scene The Current Scene readout on the left side of the Information Bar displays the 
name of the scene that is currently open on the Stage. You will learn about scenes in Chapter 11,
“ActionScripting Basics.”

Edit Scene menu If your movie contains more than one scene, this drop-down menu displays 
a list of all the scenes in your project file. You will learn how to use multiple scenes in Chapter 11,
“ActionScripting Basics.”

Edit Symbol menu This drop-down menu displays all of the symbols in your project. You’ll learn 
about symbols in Chapter 6, “Symbols and Instances.”

Zoom box It might seem like a little thing, and maybe it is in size, but the Zoom box is a handy drop-
down menu that lets you quickly zoom into and out of the contents of your Stage.

ZoomCurrent Scene Edit Scene Edit Symbol
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The Toolbox

As in most drawing programs, the Toolbox contains tools that are necessary when creating and edit-
ing artwork. This long vertical bar gives you access to just about every tool you will need to create and
modify objects in your Macromedia Flash MX projects. Each of the main tools has an associated key-
board shortcut, which is listed in parentheses next to the tool name above.

Arrow (V)

Line (N)

Pen (P)

Oval (O)

Pencil (Y)

Free Transform (Q)

Ink Bottle (S)

Eyedropper (I)

Hand (H)

Stroke Color

Black and White

Tool Modifiers

Fill Color

Subselect (A)

Lasso (L)

Text (T)

Rectangle (R)

Brush (B)

Fill Transform (F)

Paint Bucket (K)

Eraser (E)

Zoom (M, Z)

Swap Colors

No Color
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Other than docking and undocking the Toolbox and moving it around the desktop, there is only one
option for working with the Toolbox. When you hover over a Toolbox icon, a small ToolTip will appear
with the name and keyboard shortcut for that option. You can disable this feature in the General
Preferences by choosing Edit > Preferences > General. Tip: You can temporarily hide the Toolbar 
by pressing the Tab key on the keyboard. Press the Tab key again to see the Toolbar again.

The Panels
Macromedia Flash 5 saw the company’s first significant movement toward a common user interface
among all of their Web applications, including Dreamweaver, Fireworks, Freehand, Flash, and UltraDev.
With the release of Macromedia Flash MX, the ability to completely customize the work area has
streamlined users’ workflow even further. Panels are windows that contain tools and information to
help you work in your project file more efficiently. Each of the panels can be used to view and modify
elements within your project file. The options within the panels allow you to change settings such as
color, type, size, rotation, and many others. You have the ability to display, hide, move, resize, group,
and organize the panels so that you can customize the work area in any way you wish.

In the next few sections, you will learn the basic ins and outs of working with panels, including how to
dock, resize, and work with panel sets. At the end of this section is a list that provides a quick refer-
ence to the panels in Macromedia Flash MX.

WARNING | Docking the Toolbox on Windows vs. Macintosh

There is one minor difference between the Mac and Windows operating systems when it comes
to docking the Toolbox. On the Macintosh, you can’t dock the Toolbox. You can, however, click
and drag to reposition the Toolbox freely around the screen. In the Windows operating system,
the Toolbox can be docked only along either side of the document window.



2. Interface | Macromedia Flash MX H•O•T

| 24 |

Undocking and Docking Panels
Don’t think for a moment that you are stuck with the default panel layout. Just like the Timeline mentioned
earlier in this chapter, the panels can easily be undocked and docked to create new combinations that
better fit the way you work.

To undock a panel, move your mouse toward the left of the panel name, over the area where you see 
a series of dots. You will notice that the pointer becomes either an icon with four arrows (Windows) 
or a Hand icon (Mac). Click and drag the panel away from its current docked position and let go of 
the mouse button to undock it.
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Once the panel is undocked, you can drag it around the work area by clicking either on the solid bar
above the panel name or on the dots to the left of the panel name and dragging.

To redock a panel or add it to another panel group, click on the dots to the left of the panel name (you
will see the pointer change to an icon) and drag the panel onto another panel. Once you are hovering
over the other panel, you will see a dark outline appear over that panel, indicating that if you release your
mouse, you will add the panel you are dragging to the panel group you are hovering over.

Tip: A few of the panels (such as the Property Inspector) will lose their dots once you undock them. In
such cases, simply click on the panel’s solid bar and drag it over another panel until that panel is outlined
and let go of the mouse to dock it again.
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Resizing Panels

Macromedia Flash MX not only allows you to completely customize the layout and arrangement of the
panels, but also lets you change the size of each panel. To resize a panel, either drag the panel’s border
(Windows) or drag the lower right corner (Mac).

Note: A few of the panels, such as the Property Inspector and the Toolbox, cannot be resized. In panels
that can’t be resized, the pointer will not turn into the resize arrows when you move it over the border
(Windows) or you will not see the lines in the right corner of the panel (Mac).

Expanding, Collapsing, Hiding, and Closing Panels

Panel expanded Panel collapsed

To expand a panel when you see only its title, click the arrow next to the panel name once. Click the
arrow again to collapse it. (You can also simply click to the right of the panel name to either expand 
or collapse the panel.)

Press the Tab key on the keyboard to show or hide all of the panels in your document.

Choose Window > Close All Panels to close all of the panels.
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Using the Panel Options Menu

In addition to what you see in each panel, many of the panels have a control that displays a pop-up
Options menu when clicked. To display this menu, click the Options Menu control in the upper right
corner of the panel. You cannot access the pop-up Options menu if the panel has been collapsed.

Creating and Saving Panel Sets
Macromedia Flash MX gives you the flexibility to group panels in any combination you like. In addition,
you can save these custom configurations. This means that with the click of the mouse, you can com-
pletely modify the arrangement of your panels. The following steps walk you through the process of
saving a custom panel set.

Organize your panels in any way you want. For example, you can create different panel sets for different
tasks, such as drawing, animation, and working with ActionScripts. This feature allows you to quickly
organize your workspace for specific tasks.

1. Choose Window > Save Panel Layout. This opens the Save Panel Layout dialog box, which
prompts you to assign a name for this arrangement.

2. Enter any name you want and click OK. That’s all there is to it!

Switching to Another Panel Set
Changing from one panel set to another is as easy as selecting a menu option. Choose Window >
Panel Sets, and select the name of the layout you want to display. Your panels will quickly be
rearranged into that specific arrangement.

Note: Selecting Default Layout will return the panels to their default positions.
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The Panels Defined
This section briefly describes each of the panels in Macromedia Flash MX. It may seem like a lot of
new information. If so, just skim over it for now and then come back to it later as you read through the
book. You will have the chance to work with each of the panels described here in depth as you navigate
through the exercises in this book.

It is important to know before beginning that panels are accessed in one of two ways. First, you can
display the Window menu (shown above) and then choose the panel you want. Second, you can use
the panel’s associated keyboard shortcut. The method you use is a matter of personal preference, but
it’s a good idea to find one consistent way to work; it makes using Macromedia Flash MX easier.

TIP | Deleting Panel Sets

What do you do if you create a panel set that you just aren’t happy with? While there is no mech-
anism for deleting them, it is still a relatively simple process. All of the panel sets are stored in a
folder on your hard drive: the Macromedia Flash MX > Panel Sets folder. If you want to remove
one, just delete the appropriate file from this directory, and it will be gone forever.
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Here is a description of each of the panels in Macromedia Flash MX.

Toolbox Contains all the tools that are necessary to create and edit artwork, including drawing, paint-
ing, section, and modification tools. The Toolbox is one of the most frequently used panels in the program.

Timeline Controls and displays all of the static and moving elements of your Macromedia Flash MX
projects over time.

Controller Provides one way to preview your movie right inside the authoring environment. Although
there are several ways to test your movie, the Controller panel contains features similar to those on a
remote control, allowing you to stop, rewind, fast-forward, and play your movie using one panel.
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Property Inspector Acts as a one-stop shop for displaying and changing all of your most commonly
used attributes of the current selection in one panel. This context-sensitive panel allows you to modify
the current selection using only one panel, rather than having to open several panels.

Answers Provides assistance for learning Macromedia Flash MX. This panel contains links to sections
of the Macromedia Web site (http://www.macromedia.com) that contain updated information
and tutorials that can help you learn Macromedia Flash MX.

Align Gives you access to several different alignment and distribution options.

Color Mixer Allows you to create new colors in one of three different modes—RGB (red, green, blue),
HSB (hue, saturation, brightness), or HEX (hexadecimal). The Color Mixer panel also lets you add alpha
and work with different types of gradients.
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Color Swatches Displays the default 216 Web-safe colors and lets you select, add, sort, replace,
save, and clear colors.

Info Contains numerical information about the size, position, and color of the selected object. This
panel is very helpful when you need pixel-specific positions and measurements.

Scene Displays a list of all the scenes within your movie. This panel lets you quickly add, duplicate,
delete, name, or rename scenes. The Scene panel also provides a way to jump to different scenes in
your document.

Transform Allows you to numerically transform (rotate, scale, and skew) an object. This panel also lets
you create a transformed copy of an object.
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Actions Allows you to add and modify actions for a frame, button, or Movie Clip. You will learn all
about the Actions panel in Chapter 11, “ActionScripting Basics.”

Debugger Provides a way to check your movie for errors while it is playing in the Macromedia 
Flash Player.

Movie Explorer Displays the contents of your movie, organized in a hierarchical tree. You can use the
Movie Explorer panel to search for specific elements within your project file so that you can quickly
select and edit them with a few clicks of your mouse. You will learn about the Movie Explorer panel in
Chapter 17, “Putting It All Together.”
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Reference Displays detailed information about ActionScripting usage and syntax. This panel 
is an essential tool for learning ActionScripting; you will be working with it in Chapter 11,
“ActionScripting Basics.”

Output Provides assistance during troubleshooting by displaying feedback information after you test
your movie.

Accessibility Gives you some options that can help make your movies more accessible, so that they
can be seen and heard by people with disabilities.
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Components Gives you access to the seven default user interface (UI) components. These components
are essentially Movie Clips that contain complex ActionScript elements. As you will see in Chapter 14,
“Components and Forms,” the Components panel lets you add powerful functionality to your movie
without requiring you to know advanced ActionScripting.

Component Parameters Allows you to set the parameters (attributes) of a component after you have
added an instance of that component to your movie.

Library Provides a location for you to store and organize specific assets within your project, including
symbols, imported artwork, sound files, and video files. You will learn about the Library panel in Chapter 6,
“Symbols and Instances.”
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Common Libraries Provides access to sample libraries included with the program. These libraries
contain premade buttons, learning interactions, and sounds, which you can use in your movies.

Sitespring Provides a link to Macromedia Sitespring and allows you to access your Sitespring task
list. To use this panel, you need a Sitespring user account and access to a Sitespring server.
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Custom Keyboard Shortcuts

To further streamline your workflow in Macromedia Flash MX, you can create, modify, and delete sets
of custom keyboard shortcuts. Macromedia has even designed an entire interface to make this process
easy to do. One of its neatest features is that you can even assign keyboard shortcuts in Macromedia
Flash MX that match those used in other programs, like Macromedia Fireworks, Macromedia Freehand,
Adobe Photoshop, and even earlier versions of Macromedia Flash. You may think that this feature is
only for power users, but you should still be aware of it. Besides, you will be a power user in no time!

The steps that follow outline the process of creating, modifying, and deleting custom keyboard shortcuts.
This isn’t an exercise that you have to complete; if you like, just make a mental note of it for later use.

Delete Set

Rename Set

Duplicate Set

Commands list

Add/Delete Shortcut

Shortcuts list
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Creating a New Shortcut Set
1. Choose Edit > Keyboard Shortcuts (Windows) or Flash > Keyboard Shortcuts (Mac) to open
the Keyboard Shortcuts dialog box.

2. Click the Duplicate Set button to create a copy of the current set. This will ensure that you are
working from a duplicate so you don’t mess up the original set.

3. Enter a name for your custom set. You can name it anything you want, but it’s best to stick to a
meaningful name that you can recall later. Click OK.

4. Click to the left of any of the options in the Commands list to drill down and display the keyboard
shortcuts for that menu. Select the option you want to change.

5. Click the + button to add a shortcut (click the – button to delete the selected shortcut). You can
create multiple keyboard shortcuts for one option. (However, that may not be such a good idea.)

6. Click the keyboard shortcut you want to assign to this option or enter it in the Press Key text 
box. Click the Change button to confirm your selection and assign it to the menu item. Note: If the 
key combination you selected is already in use, you will get an error message at the bottom of the 
dialog box.

Well, that’s enough of the interface for now. The following chapters are full of hands-on exercises
where you will work with these interface elements. So go ahead and turn the page to get started.


